Can't login via Ctrl-Alt-F2 with v6 kernel

After installing nix and rebooting, I found that I could no longer via lightdm (w/XFCE). When using Ctrl-Alt-F2, my screen was stuck at “Starting system udev version 252.3-1-arch”. This has never happened to me before.

I proceeded to remove nix and all its files, removed the groups it created and rebooted again - same exact problems. I double-checked my fish-shell configs to see if there were any errors and nothing jumped out at me. I was finally able to get back into the system by switching back to bash and using the v5.15.82 kernel (updated this afternoon).

What I noticed during the boot was the 5.15 kernel posted all of the normal messages, but the 6.0 kernel still did not. I can login via Ctrl-Alt-F2 now, but only with the 5.15 kernel; lightdm and fish are now working with both as before. Since the system was updated today, the initramfs for both were also updated.

The only thing I’ve done that would have affected booting/initramfs was added vfio modules to /etc/mkinitcpio.conf:

MODULES="vfio_pci vfio_virqfd vfio_iommu_type1 vfio crc32c"

I did this about 3 weeks ago (for GPU pass-through) and everything has been working fine. To be honest, I have no clue how any of this is related, if it’s related at all. I did check the systemd journals from an Arch chroot and there were no errors from any service, let alone lightdm.

A similar issue is being discussed here:

The solution in this case:

i915 is now blacklisted and kms early loading enabled.

I can now access the virtual console.

To summarize:

Early KMS loading by itself did not seem to affect the behavior of the virtual console.
It was the blacklisting of i915 that yielded the desired result.

I’m only using (2) Nvidia GPUs, so the aforementioned solution doesn’t apply to me. What I’m failing to understand is why this is only affecting the 6.x kernel branch and not the LTS one.

This is my current /etc/default/grub:

GRUB_DISTRIBUTOR=$(lsb_release -is)
GRUB_CMDLINE_LINUX_DEFAULT="rd.driver.pre=vfio-pci loglevel=3 nowatchdog nvme_load=YES nvidia-drm.modeset=1 amd_iommu=on iommu=pt"
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

OK, I finally made some progress, but also some regression:

  • Adding the Nvidia modules to initramfs allows me to see the entire boot-up again in the v6.1 kernel. However, the display crashes and I get no login screen: (this is happens with v5.15 kernel as well)
  • Removing nvidia-drm.modeset=1 changes nothing

Anyone have any suggestions?


Your crash from last log looks like this one here:

I guess you will need to configure VFIO mappings correctly for audio to work with 2 nvidia cards, or at least not to crash the display.

Thanks for the reply. I don’t think your link applies to me, as my (2) audio devices have different IDs. I also don’t pass through the GPU’s audio device anyway (sound on my monitor is horrible), instead I use the motherboard’s built-in sound card.

Since the link did not mention whether it’s using early module loading, I can’t tell if it’s related or not. I do know that without early module loading, I get no errors other than what my OP shows.

1 Like