Can't login as root in tty

I can’t login as root in tty console, but with my user works fine
For me enable root user and password, but not working in tty
I logout form user and alt+f2
Type root then password root but fail login incorrect

Are you using the correct root password? Try change root password to what your user password is.

sudo passwd root

Yes put correct password root
When login user and su root work but after logout user in tty not login root !!
I change password root also

There is a problem. When I logout, I don’t have the right to choose another user in graphical mode,too

This is not normal so i would say is not a fresh install so something that you have done which only you know what that is. :wink:

When installing endeavoros set separta password for root

This is something i haven’t done so i’m not sure. But i will test in vm just to see.

Edit: I installed xfce in a vm with separate root password. I am able to log in under tty to user and also to root using su. I am also able to log in as root in tty.



Edit : I am not exactly sure what you are doing but i can logout in tty and log back in as root.

Edit2: I am also able to change the root password to match the user.


1 Like

Strangely, it doesn’t work for me
I installed luks mod ,It can be related.
Maybe for me security locked root user

You didn’t mention that in the beginning?

Edit: Is your luks password the same as your user?

1 Like

In menu xfce When click to profile image show erro
“Failed to execute chlid mugshot no such file or directory” can be related
Not same password

I don’t know what this means.

Edit: I try with separate luks password and user and root.

Edit2: I used separate password for luks, separate password for user and separate password for root. I was able to boot on luks and log in and go to a tty and log in under user and root. I was able to change the root password to the same as the user. I was able to log out and log back in under root with out issue.

Edit3: I have no issues. Something you do or some issue with the install.

1 Like

Maybe a matter of locale-settings and/or differing keyboard-layouts?

1 Like

It works fine for me in vm so has to be some other issue like you say. I just don’t know would be guessing wrong usually. :laughing:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.