Can't install on a Lenovo ThinkCentre M75q-2 (Ryzen 4350GE)

Hi there,

I’m trying to run the live USB on a Lenovo ThinkCentre M75q-2 but it gets as far as trying to configure X.Org and then just crashes with Server terminated with (1).

I’ve turned off Secure Boot, Fast Boot and IOMMU in the bios, but it still won’t progress any further.

Any help would be much appreciated. Thanks.

Did you check the integrity of your downloaded ISO?

How did you make the bootable USB?

Does your USB boot up on another device?
If you have the possibility, please check.

Also, could you post a link to the spec of this machine?
I haven’t found it in a casual search.

Thanks for the reply. Sorry, I forgot the ‘q’ part of the model - it should be Lenovo ThinkCentre M75q-2.
You can find it here:

How do I check the integrity of ISO? sha512sum -c EndeavourOS_Apollo_22_1.iso.sha512sum just gives me sha512sum: EndeavourOS_Apollo_22_1.iso.sha512sum: No such file or directory

1 Like

You need to run it from within the same directory containing the ISO file.

I am definitely in the same directory.

Are you sure the filename should have ‘.sha512sum’ appended to it? When I remove this, I get: sha512sum: EndeavourOS_Apollo_22_1.iso: no properly formatted checksum lines found

Did you download the sha512sum file as well into the same directory?

1 Like

Finally got the sha512sum working and it confirms that the iso is OK.


At a glance, i am not seeing anything particular in the spec of the machine which would make it “incompatible” with EnOS out-of-the-box.

Please wait for more comments from other forum members.

1 Like

Does your USB boot up on another device?
If you have the possibility, please check.

1 Like

How did you create the live USB? as @pebcak asked. It does matter.

I created it using USB Image Writer running on Plasma.

The problem seems to be with initialising the amdgpu driver for some reason. I’ve now had the chance to try it with Manjaro and Gecko, where it also fails, either with a blank screen or with the following message: ERROR VGACON disable amdgpu kernel modesetting

Try adding the following kernel parameter at boot.


Edit: When booting press e for edit at the grub menu and add the parameter in the default grub command line.

1 Like

you can keep iommu on for boot
if possible , open a terminal ( or TTY with Ctrl + Alt +Fn ( 2 to 7 )
and return

inxi -Fza 

other option on boot command kernel are
“amd_iommu=on iommu=pt”

It didn’t make any difference. If I add it to the default boot it just gives me a blank screen and if I add it to the nomodeset boot it just gives me the original X.Org Server terminated with (1) error.

The only one that has partially worked so far is with Ubuntu when I select Ubuntu (Safe Graphics). That allows me to set up and complete the installation. But when I reboot, I just get a blank screen again! Aargh!

What do I log in with?

Also possibly try

amd_iommu=on iommu=pt pci=noats

OK, I’ve tried changing from HDMI to DisplayPort and…now everything works! Don’t know why it’s objecting to HDMI as it’s fine on my Dell Optiplex. Maybe amdgpu is just more fussy about the connection for some reason?

1 Like

Glad you got it working by trying something else.

1 Like

Thanks for your help everyone :smiley:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.