Can't install Nvidia drivers after update

After updating the system yesterday i got stuck in the “starting” screen after booting. I followed the instructions of this post: [FAQ] Computer doesn’t boot, boots to a black screen, or stops at a message
The first option did not help, the second option did nothing yesterday, but today it did. I used startx and x started. I tried changing display manager from lightdm to gdm and now i can get into the DE.
But it seems I have no graphics drivers, the resolution and aspect ratio is wrong, and from this command inxi -FAZ --no-host | eos-sendlog i got this: Graphics: Device-1: NVIDIA GA104 [GeForce RTX 3070] driver: N/A Display: x11 server: X.Org v: 21.1.7 with: Xwayland v: 22.1.8 driver: X: loaded: vesa unloaded: fbdev,modesetting gpu: N/A resolution: 1024x768~76Hz API: OpenGL v: 4.5 Mesa 22.3.6 renderer: llvmpipe (LLVM 15.0.7 256 bits)

I have tried using nvidia-inst several times, but it always gives the message “==> nvidia-installer-kernel-para: info: systemd-boot or grub not in use”

Any tips for fixing this?

I fixed the driver issue by manually installing the nvidia drivers with pacman -S nvidia.
I still can’t get past the starting screen with lightdm as display manager, but using gdm works.

In order to understand what exactly broke your system, you should check your pacman log and see what happened during the last update procedure. My guess is it was not completed successfully, or with no errors.

About the display managers, you may have edited/created some Xsetup script for LightDM, which may need modification, or have some xorg.conf.d custom conf file. :person_shrugging:

How old is your system?
Could you post these logs ?

inxi -SMGIaz
ls -l /etc/X11/xorg.conf.d/*.conf

My system is about a little over a year and a half old, but i first used manjaro, and changed to endeavouros after about a month i think, so I’ve had this endeavouros a little under a year and a half.

  Kernel: 6.1.12-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-linux
    root=UUID=8ce13c05-c48e-49af-99df-6556cbdf25d1 rw quiet
    resume=UUID=6b2f63c6-986f-489d-a21e-6cd16ad96b37 loglevel=3 nowatchdog
  Desktop: KDE Plasma v: 5.27.1 tk: Qt v: 5.15.8 info: latte-dock
    wm: kwin_x11 vt: 2 dm: 1: GDM v: 43.0 2: LightDM v: 1.32.0 note: stopped
    Distro: EndeavourOS base: Arch Linux
  Type: Desktop System: Gigabyte product: X570 AORUS ELITE v: -CF
    serial: <superuser required>
  Mobo: Gigabyte model: X570 AORUS ELITE v: x.x serial: <superuser required>
    UEFI: American Megatrends v: F31 date: 12/31/2020
  Device-1: NVIDIA GA104 [GeForce RTX 3070] vendor: Micro-Star MSI
    driver: nvidia v: 525.89.02 alternate: nouveau,nvidia_drm non-free: 525.xx+
    status: current (as of 2023-02) arch: Ampere code: GAxxx
    process: TSMC n7 (7nm) built: 2020-22 pcie: gen: 4 speed: 16 GT/s
    lanes: 16 ports: active: none off: DP-3 empty: DP-1,DP-2,HDMI-A-1
    bus-ID: 08:00.0 chip-ID: 10de:2484 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.7 with: Xwayland v: 22.1.8
    compositor: kwin_x11 driver: X: loaded: nvidia
    unloaded: fbdev,modesetting,vesa alternate: nouveau,nv
    gpu: nvidia,nvidia-nvswitch display-ID: :1 screens: 1
  Screen-1: 0 s-res: 2560x1440 s-dpi: 108 s-size: 602x342mm (23.70x13.46")
    s-diag: 692mm (27.26")
  Monitor-1: DP-3 mapped: DP-4 note: disabled model: Dell S2721DGF
    serial: <filter> built: 2020 res: 2560x1440 dpi: 109 gamma: 1.2
    size: 597x336mm (23.5x13.23") diag: 685mm (27") ratio: 16:9 modes:
    max: 2560x1440 min: 640x480
  API: OpenGL v: 4.6.0 NVIDIA 525.89.02 renderer: NVIDIA GeForce RTX
    3070/PCIe/SSE2 direct-render: Yes
  Processes: 289 Uptime: 1h 57m wakeups: 1 Memory: 15.57 GiB
  used: 5.54 GiB (35.6%) Init: systemd v: 253 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: pm: pacman
  pkgs: 1402 libs: 416 tools: yay Shell: Bash v: 5.1.16 running-in: konsole
  inxi: 3.3.25

-rw-r--r-- 1 root root 232 Sep 11 2021 /etc/X11/xorg.conf.d/00-keyboard.conf

I also checked the pacman log and found this:

[2023-02-22T13:49:16+0100] [ALPM-SCRIPTLET] Error! Bad return status for module build on kernel: 6.1.12-arch1-1 (x86_64)
[2023-02-22T13:49:16+0100] [ALPM-SCRIPTLET] Consult /var/lib/dkms/nvidia/525.89.02/build/make.log for more information.
[2023-02-22T13:49:16+0100] [ALPM-SCRIPTLET] ==> WARNING: `dkms install --no-depmod nvidia/525.89.02 -k 6.1.12-arch1-1' exited 10
[2023-02-22T13:49:16+0100] [ALPM-SCRIPTLET] ==> dkms install --no-depmod nintendo/3.2 -k 6.1.12-arch1-1
[2023-02-22T13:49:16+0100] [ALPM-SCRIPTLET] Deprecated feature: REMAKE_INITRD (/usr/src/nintendo-3.2/dkms.conf)
[2023-02-22T13:49:18+0100] [ALPM-SCRIPTLET] Module version  for hid-nintendo.ko.zst
[2023-02-22T13:49:18+0100] [ALPM-SCRIPTLET] exactly matches what is already found in kernel 6.1.12-arch1-1.
[2023-02-22T13:49:18+0100] [ALPM-SCRIPTLET] DKMS will not replace this module.
[2023-02-22T13:49:18+0100] [ALPM-SCRIPTLET] You may override by specifying --force.
[2023-02-22T13:49:18+0100] [ALPM-SCRIPTLET] Error! Installation aborted.
[2023-02-22T13:49:18+0100] [ALPM-SCRIPTLET] ==> WARNING: `dkms install --no-depmod nintendo/3.2 -k 6.1.12-arch1-1' exited 6```

There you are!

About LightDM, you can check old journal logs (pointing to a lightdm-failed boot session), and/or lightdm log files, to see error messages.
Additionally, you can check if there is any Xsetup modified script (path is in lightdm.conf files).

[+0.00s] DEBUG: Could not run plymouth --ping: Failed to execute child process “plymouth” (No such file or directory)
I found this in lightdm.log.old

I suspect this means that the plymouth module was not included in the kernel for some reason. (in mkinitcpio in MODULES array, and the equivalent for dracut).
Best check plymouth Archwiki article to confirm proper installation.