Can't install EndeavourOS getting mce error

Hey all,
I’ve been trying to install EndeavourOS on my PC for the past few days and have been looking all over the forum for help and haven’t had any luck. Some context:
I have a working install on my laptop and want to utilize my powerful desktop for research computing (has much more power than my laptop) and I get the same error Everytime and then it just hangs. I’ve run memtest and there were no issues. I fully cleaned out my PC of any and all dust. I’m not sure what to do at this point and was hoping for help since I love this distro. Any help is appreciated. Here’s a picture of how far I get

any Bios setup done on performance optimization?

The error you’re encountering, specifically related to “Machine Check Exception” (MCE), typically indicates a hardware issue.

We need more information to help you. You can start by telling us your hardware?

Did you fully update your BIOS?

If you are using a CPU with Hyper-Threading (Intel) or SMT (Simultaneous Multithreading - AMD), try disabling it in the BIOS/UEFI settings and see if the problem persists.

Try a different kernel.

1 Like

is this from booting into installer ISO or after installing and try booting into system?
You could try latest ISO rebuild as it has a different kernel (newer one):

My BIOS are fully updated. My CPU is 13th Gen Intel(R) Core™ i5-13600K. Motherboard is MAG Z790 Tomahawk WIFI. I’ll look into a different kernel, I tried to install calameres and had the same issue. I also disabled hyper threading and it still didn’t work

I hadn’t checked the bios for performance stuff, Do you know where i can find it? Also I am booting from a flash drive, have not installed yet

if you do not set it it will not be set anyway… only if device is may second hand and previous user done that… if the erros is not related to a real hardware error fail… it can only be that… reset bios and check to update it to latest version if the used one is outdated.

Updated my bios (didn’t realize they weren’t updated) and changed the BIOS settings mention so far and this is as far as I get now. Now using the latest release.

Machine Check Exception (MCE) is an error that occurs when a computer’s CPU detects a hardware problem. Typically, the impending hardware failure will cause the kernel to panic to protect against data corruption. Machine checks can indicate failing hardware, system overheats, bad DIMMs, or other problems.

CPU Overheating or a permanent CPU damage.

Check that the ram is installed and seated properly. Re-check the CPU.

Edit: This is a very new motherboard so it could also be some UEFI Bios setting.

I see the latest UEFI Bios update also has ME firmware with it to download and apply. Did you do that also? Not sure if you had Windows on installed to do this?

that’s true and it says also that this is working well, so checking seat of cpu and RAM is indeed the first thing to check… i was in the thinking the system was in use already only installing new OS…

Start with a mem test after re seating memory modules.

If that did not help try reset bios (or remove the cmos battery for 10 minutes) and load bios defaults after.

If that doesn’t help there may be socket pins damage, so try carefully to remove the cpu and inspect the socket pins (with a big magnifier) If that looks oke re seat the cpu and try again.

If all above does not help i think the motherboard, cpu or memory is broken. Power supply is unlikely faulty but not impossible (the power to cpu may have a issue)

undervolting can trigger the error message indeed from what i read about…

I do have a working windows installation on my machine. It’s only when I go to install endeavour that I get this issue. I’m going to inspect the CPU and go from there.

Would be nice if you have told us this before.

And it is very unlikely if there is a hardware problem this not occurs on Windows.

If you try a live boot from a different distro (ubuntu, mint etc) does the problem occur as well?
This to rule out a specific problem with EOS

Did you do the firmware ME update in Windows when you updated the UEFI Bios?

I did not. I was not totally sure how to so I updated to the second most recent BIOS which did not require that. Do you think I should try the most recent BIOS update that has me update those things as well?

If it were me i would. The instructions are there on the support website to do it from Windows. One of the ME files is just instructions. The other is the actual firmware update.

To update the ME firmware:

1.Unzip file.
2.Execute MSI ME FW Tool.exe in windows and then it will automatically complete the entire ME FW update.

I created a live boot of ubuntu and was unable to load into the live environment. Sorry about not mentioning the windows installation previously.

could be linux is simply more sensitive on that error…