Can't Install EndeavourOS Cassini on Mac Book Pro 5,3 (15 inch 2009 2.66ghz)

Hello fellow Endeavour fans!

I’ve been using EndeavourOS after switching from Manjaro, for two years on my main PC, my Raspberry pi 400 (arm version), and Also my old MacBook Pro, which is the computer I am now unable to launch the latest live-ISO.
I’ve been installing Endeavour OS for a long time on this old macbookpro Budgie to try and make it look like the latest macOS, but then wanted to also try fedora workstation, which didn’t work, so I went back to EndeavourOS . So I boot this time with Installer 22.12 Cassini, I couldnt boot into it at all, the MacBook Pro giving me a kernel panic… Thought I screwed something up when I tried installing fedora, so to test, I found a 22.9 artemis Nova live iso, which I got into another USB stick… and that one worked perfectly!
So I dunno if there is a specific bug with 22.12 and old hardware, but man I’d love to install it on my macbook pro, specially cause budgie now uses Nemo instead of nautilus!

I keep getting this initramfs unpacking failed kernel panic when trying to launch the Live iso/ USB:
initramfs unpacking failed: ZSTD-compressed data is corrupt
failed to execute /init (error -2)
Then proceeding to get a Kernel panic and system info as shown on picture down below. Like I said, 22.9 boots perfectly. Hope somebody can help me with this, or this can get fixed in an updated installer in the future. :slight_smile:

Hardware information:
MacBook Pro 5,3 - 15 inch Core 2 duo P8800 @ 2.66ghz
8gb ddr3 1333MT/s
Nvidia 9600m GT/ 9400M

Here’s what the Macbook pro reports trying to boot with the Cassini Live Iso/USB (

Here is a strange story about autodetect of RAM and resetting to the factory default:

> When I went into the BIOS setup to check the memory (DRAM) settings, I found that the defaults (which were supposed to be auto detected by the motherboard, and based on the particular hardware installed) were not in close agreement with the specifications for the memory from the manufacturer. It took a lot of attempts to get thing to work reliably and the way I want them too, but FINALLY!!!
> I suspect the autodetect feature of the motherboard was incorrectly loading memory settings on the initial boot up. Most likely having something to do with when in the bootup sequence the autodetect took place. As stated in the problems description, once I had gone into the BIOS saved and exited (even if I didn't change anything), the system would boot properly. I suspect that this "detour" to the BIOS settings during bootup, gave the autodetect function sufficient time to work properly or allowed the actual hardware sufficient time to respond correctly.
> I used the manufacturer's DRAM settings, which I looked up earlier, in the BIOS setup. Actually, I still allow the motherboard to autodetect the the exact settings, but I have specified the correct type of memory and memory overall speed for the unit to query within. This narrowed the range of acceptable responses the autodetect could provide. Now when I boot up, everything works the way it is supposed to.

Hello eso!

This is a mac, and sadly no way to go into bios and lowering the ram speed. Also, this is factory ram. bought it with 8gb (2x4gb), and had never given me any issues with any other linux distro, or MacOS or Windows for that matter. So it has me really puzzled. Either way, I installed the latest endeavourOS (cassini 22.12) on dual boot on my Main PC, and I found out, there’s little to no difference if I Install 22.9 and just update and add Nemo myself. :slight_smile: It’s still puzzling why 22.9 Artemis Nova LiveISO gives me no problem, and 22.12 LiveISO gives me that error, and its unbootable.

All ISO’s before cassini (including Artemis Nova LiveISO) use grub by default. Cassini is the first ISO to use systemd-boot by default. Perhaps that might be the problem with the Mac Book Pro.

I believe there is an option in cassini to optionally use grub.

See this URL for cassini’s release notes:

A blurb from that web site.

And it ships with these new features:

Added a choice of bootloaders as well as the ability to not install a bootloader
(systemd-boot is default selected)

Switched to dracut from mkinitcpio


I was about to post my issue about Cassini kernel panic-ing when I tried to install on my Macbook Pro.
Then I found this post.
This is a older Intel Core i5 gen 2 ~ 2011.
I screen after panic looks the same. I’ve previously had install several version of EOS. Most recently I had Arch installed the ‘arch’ way.

I’ve read this post, but have no idea how to install with Cassini

This is not related. the boot options were changed only in calamares. The OP has problem even booting the ISO.
The way the ISO is made hasn’t changed from 22.9 to 22.12.

So I guess the issue is the new kernel??
Or is it the initramfs @dalto ?

As far as I know, none of our ISOs have ever used grub. They all use systemd-boot/syslinux.

If I had to guess, it is either hardware related or something to do with the newer packages.

I could be changes to the kernel, mkinitcpio, zstd or the libraries that support those.

Since I don’t have any similar hardware to test on, it is all just speculation on my part.

Hello. this problem was also present on my device.

MacBook Pro 5,5 (13-inch, Mid 2009) Core 2 duo P7550 @ 2.261ghz
8gb ram
NVIDIA GeForce 9400M

I was using 22.9 Artemis Nova.
I solved it this way.

open terminal on Artemis Nova.

  1. Install the Program
    yay refind

  2. run the install script

shutdown pc
plug in usb Endeavouros_Cassini_22_12.iso
boot and F2
select Endeavouros_Cassini
Install and enjoy.

Thank You Endeavouros Team.
I loved it so much.


Are you saying you installed refind on the live usb first and then booted into it to install?

No as it is written here. (Articles 1 and 2)

Only Installed refind Endeavouros Artemis Nova.

I know how to install refind. I was just confused because the OP is trying to install EndeavourOS. So he doesn’t have it installed even. What you wrote and what I’m asking is did you install refind on the live ISO first and then boot on it and install to your Mac because that’s the way I’m reading it. It doesn’t read to me that you already have it installed and then you used refind because of this issue when booting? :thinking:

I think @deepblue is saying they had the same problem on their installed system and installing refind solved that issue. It may be something of a red herring to the OPs problem.


excuse me.of course you know refind install. :sweat_smile:
i tried to explain what i did.but I guess I was misunderstood because I used the translator.
I did not install refind on live usb.

It was a situation I encountered when I wanted to update Artemis nova to Cassini.I couldn’t install the cassini.I was able to install it with refind.


I think i understand it now. Of course you installed refind on the system that was installed first and then it was able to boot the new Cassini live ISO.

1 Like

I’m confused. I can’t boot the Cassini IOS via USB period. It locks with a kernel panic; screenshot above. So I’d need a fixed ISO or a method to fix the ISO USB some way.

yes exactly that

Sorry I don’t know why i was originally confused by the post? :grinning:

1 Like

Yeah, it is better to disregard the above the posts. They probably won’t help you.

Someone who has this hardware has to experiment to determine what is causing it before we can find a good workaround.

Well I have the Macbook Pro and I’m willing to try to figure this out, but not sure how. In the days of PC development systems I’d hook up a JTAG debugger (Probe Mode) and watch it boot, but not something you can do on a Macbook.

1 Like

which version are you currently using?Artemis Nova?
Have you tried refind?