Can't hear no sound through HDMI

I just installed EndeavourOs but I can’t get any sound to play on my hdmi television. All sounds played fine on Linux Mint which I just replaced. How do I start solving this sound issue?

PS: Please don’t tell me to go back to Mint.

PSS: I installed several desktop environments such as KDE, Gnome, Cinnamon, Budgie incase that matters.

PSSS: My computer is an Intel NUC 12.

Hello and welcome aboard.

I’ve had - and solved - the same identical problem back in 2023-02-23 No audio - pulsemixer Dummy Output after kernel update 6.1.12-1-lts: Module snd_hda_intel_codec not found in directory /lib/modules/6.1.12-1-lts

To cut it short: blame it on kernel(s) vers. 6.x.

Get an UPDATED, regular kernel BUT still belonging to gen. 5.x: for instance

pacman -Ss linux-rt-lts linux-rt-lts-headers


, hence:

sudo pacman -S linux-rt-lts linux-rt-lts-headers
sudo grub-install
sudo grub-mkconfig -o /boot/grub/grub.cfg

Reboot, and you’re done.

For the more details pls check The old thread

Or feel free to ask me.
Peace, Piero

I have an UEFI installation not legacy bios / grub.

Same as me on the PC affected by that glitch: or do you mean you boot via systemd?

Well in that case just use what it takes to rebuild your bootloader: the key is in that kernel - regardless of the bootloader.

@Dissuntat A less scientific but a working solution to use pulseaudio. Maybe it’s not an optimized version.

systemctl --user mask pipewire-pulse.service pipewire-pulse.socket
yay -S pulseaudio    #accept with yes/si
yay -S pulsemixer
systemctl --user stop pipewire.socket
systemctl --user stop pipewire.service
systemctl --user start pulseaudio.service
systemctl --user start pulseaudio.socket

Use pulsemixer and F3 to selet HDMI output. A logout/login in case of necessity.

1 Like

Or configuration tab in pavucontrol?
It works with pipewire as well.

The laptop is not connected to an external monitor so that’s why it say “unavailable” for all those HDMI outputs.


Yes I would like to try this pipewire to pulseaudio switch, but it fails :frowning:

[me@mymachine ~]$ yay -S pulseaudio 
Sync Explicit (1): pulseaudio-16.1-6
[sudo] password for user: 
resolving dependencies...
looking for conflicting packages...
:: pulseaudio and pipewire-pulse are in conflict. Remove pipewire-pulse? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: removing pipewire-pulse breaks dependency 'pulseaudio-bluetooth' required by gnome-bluetooth
:: removing pipewire-pulse breaks dependency 'pulseaudio-bluetooth' required by gnome-bluetooth-3.0
error: could not set install reason for package pulseaudio (could not find or read package)
 -> error installing repo packages

My apologies. I’m not on Gnome. As one of the main advatagies of EOS is the fast install, I made a test site for Gnome. I did the same for Arco where it is working out of the box.:

inxi -aA
  Device-1: Intel Ice Lake-LP Smart Sound Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_icl
    bus-ID: 00:1f.3 chip-ID: 8086:34c8 class-ID: 0403
  Sound API: ALSA v: k6.2.11-arch1-1 running: yes
  Sound Server-1: JACK v: 1.9.22 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.69 running: yes

How naive and silly I was to compare the installed package lists of the two systems. pacman -Qqe > pkglist1.txt
I started removing pipewire-alsa -jack -pulse with -Rcns
and install pulseaudio -alsa -bluetooth and rebooted
into the console user prompt.
So, instead of deep-diving I wait for the correct solution from the community.

Heres what my inxi -aA looks like:

$ inxi -aA
  Device-1: Intel Alder Lake PCH-P High Definition Audio driver: snd_hda_intel
    v: kernel alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:51c8 class-ID: 0401
  API: ALSA v: k6.2.11-arch1-1 status: kernel-api tools: alsamixer,amixer
  Server-1: PipeWire v: 0.3.69 status: off with: 1: pipewire-pulse
    status: off 2: wireplumber status: off 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl

Maybe this information is also usefull:

$ systemctl --user status pipewire
● pipewire.service - PipeWire Multimedia Service
     Loaded: loaded (/usr/lib/systemd/user/pipewire.service; disabled; preset: enabled)
     Active: active (running) since Mon 2023-04-17 12:35:32 EEST; 3min 16s ago
TriggeredBy: ● pipewire.socket
   Main PID: 2675 (pipewire)
      Tasks: 2 (limit: 37976)
     Memory: 5.0M
        CPU: 147ms
     CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire.service
             └─2675 /usr/bin/pipewire

huhti 17 12:35:32 nuc systemd[689]: Started PipeWire Multimedia Service.
huhti 17 12:35:32 nuc pipewire[2675]: mod.rt: Can't find org.freedesktop.portal.Desktop. Is xdg-desktop-portal>
huhti 17 12:35:32 nuc pipewire[2675]: mod.rt: found session bus but no portal

$ systemctl start pipewire.service
Failed to start pipewire.service: Unit pipewire.service not found.

If your sound issue is not resolved, please remove the solution mark.
As it is, it shows as a solved topic in the flow and unlikely to get much attention.

Yes indeed. Thank you for pointing this out. I will remove the solution mark.

1 Like

Also please have a look at the following articles in our Wiki regarding the use of Pipewire resp. Pulseaudio:

1 Like

Thank you. This link ( helped me solve the issue. I almost did not get past not being able to remove a crucial depency breaking package gnome-bluetooth-3 and 3.0 (hence “–nodeps --nodeps”).

Here are the commands that were required get sound for my computer (an Intel Nuc 12 with sound through hdmi cable):

$ sudo pacman -R --nodeps --nodeps gnome-bluetooth-3
$ sudo pacman -R --nodeps --nodeps gnome-bluetooth-3.0

$ sudo pacman -S pulseaudio
$ sudo pacman -S pulseaudio-alsa pulseaudio-jack pulseaudio-bluetooth

$ systemctl --user stop pipewire-pulse.service
$ systemctl --user start pulseaudio
$ inxi -Aaz

# + a reboot was required in the end
1 Like

Great! Glad you could resolve the issue! :wave:t5:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.