Can't get to installation on acer aspire a717-72g

As the title states, I can’t get to the installation media. The startup looks fine as it’s initially booting up, then gets stuck at a black screen with an arrow. Im trying to install it on a laptop with an i5 processor, 8 gigs of ram and an nvidia 1050 4gb. Ive tried using rufus on my desktop with gpt partition scheme and iso mode. Any suggestions?

Welcome @jay
Try editing the boot menu with E and add modprobe.blacklist=nouveau to the end of the line and try.

ISO is ready to go and if you change the boot process it will mostlikely fail to boot, and this is what rufus is doing if you choose different modes… . better take etcher (run at Windows too) or using DD mode on rufus.

And as the device only have nvidia GPU (as it looks like) available… blacklisting nouveau will not help… (latest ISO) it will boot on modsetting driver from Kernel on Nvidia chips (GPU)
Do you check BIOS/Firmware setting if there are GPU related settings?

I dont see anything about gpu related settings. Just intel vtx and intel vtd enabled in advanced. Ill give etcher a shot and report back.

Tried etcher and still the same thing. @ricklinux pressing e at boot doesnt do anything for me.

[tab] instead of “e” will be what you need for Syslinux on the boot menu for the ISO… and this shows us that system boots in legacy (BIOS) {msdos} mode… not EFI… {gpt}
It seems to be that there where two issues… first GPU related, may system try to use the intel GPU from Processor ? or secure boot is not disabled?
i would try blacklisting intel GPU also:
modprobe.blacklist=i915

@joekamprad when I do tab at boot, it brings me to my bios, and when I do it it after boot it brings me to the usb options. I tried changing the rst with optain to ahci. It gives an error every time about failed to start store a token as an efi variable. Not sure if that helps. Switched to bios mode and still the same issue with the black screen and cursor. I take that back, now it’s just a black screen, no cursor. I also have 2 intel options enabled in bios. Intel vtx and intel vtd. I also have a sata configuration which has ports 0 and 1 enabled. Boot mode only shows uefi. Secure boot is disabled. Tpm ( tcm) is enabled. Fast boot is enabled.

Did you check your Uefi Bios and make sure secure boot is turned off. Also turn off fast boot and try again.

@ricklinux as stated above, secure boot is disabled. Turning off fast boot and restarting produces the same results.


I also get this error after every boot.

Did you try modprobe.blacklist=i915 modeprobe.blacklist=nouveau

I’m sorry, how do I do that?. I tried hitting e at boot like you suggested and that just put eeeeeeeee into the boot process of the usb. I also tried tab and that brought me to recovery at boot and to the usb after boot.

The tab has to be pressed at the appropriate time when it boots. You have to be quick when it comes up to the menu.

Tab isn’t doing anything now. I’m smashing it as soon as I hit the power button and it’s just booting into usb.

You press it as soon as the menu comes up.

Yeah I’m trying that. Before the acer logo appears all the way until the menu pops up.

The menu i’m referring to is the boot menu that loads from the usb? Are you getting that?

Yes thats the same menu im mentioning. If i do it pre-boot or when the menu pops up, nothing happens. It just cancels out the three second countdown.

I helped you before with installing and or fonts. Did you get a new laptop?

Yes sir. I got endeavour set up with a multiboot on my desktop, but this laptop gets extremly hot with windows and games. I swear it seems this laptio just hates arch. I have not tried installing arch the arc way on here, but it seems to like the pop os nvidia version. I cant install endeavouros, KaOS or manjaro gnome. Manjaro gets to the DE then locks up.

If I remember correct, this means you have optane memory? If I’m wrong, just quit reading this post. :slight_smile:

I had to deal with one Acer with optane memory, and I wasn’t able to use that at all. The Linux installer didn’t recognize any disk with optane enabled. When I disabled optane, Linux installer did recognize the disk. But I couldn’t make that change permanent because I wasn’t allowed to remove Windows from the disk… :wink:

So I think (but never tried it myself …) that you need to disable usage of optane (from BIOS or Windows?) and then try again. Note that this probably will remove everything from the disk, so if you have anything valuable there, make a good backup first.