Can't get processing lang to work

I have installed processing from the website (not from archlinux) https://processing.org/download/

and I tried to install different java versions via yay -S java-runtime, sometimes it works the entire program but most of the time it doesn’t.

My program first asks the user to get the song but while it prompts it shows this error message on the console (of processing)

Then after importing the song and I end up running the entire program it does this.

I am not too sure what Arch Linux has a huge issue with java?

It’s been quite some time since I’ve written java code, but that back trace looks to me like the program is not handling an error condition or missing resource gracefully. :frowning:
I checked what yay -S java-runtime does and it installs jre11-openjdk-11.0.8.u10-1 which is what I use for intellij-idea-community-edition so I’m pretty sure this isn’t an issue with the JRE install.

1 Like

on Windows when I compiled it for Linux at first it worked then it didn’t work after a system reboot :frowning:

AUR has many alternative packages:
processing processing4 processing4-git processing-bin processing-jdk8

Why not one of them?

1 Like

They were even worse. it woudlnt’ even run the program :frowning: