Can't get Brother MFC-L2700DW working

Have packaged debian driver that works on Manjaro and Arcolinux but not on Endeavour os or Arch. Followed your Wiki on printers and installed the packaged drivers. Cups is installed and enabled. Can someone walk me through this? BTW have used this packaged Debian driver to install on the distros mentioned above. Thanks in advance.

Hello @eddbee11
You can try installing the Brother printer MFC-L2700DW with yay

yay mfc-l2700dw


Or preferably (typo fix :wink:) this:

 yay -S brother-mfc-l2700dw
1 Like

The drivers from the AUR do not work nor are they maintained. Therein lies the problem.

Actually the printer driver looks like being up to date (same version as the Brother is showing at these pages:

Exactly what error did you have while installing this package?

It’s probably not an error per say but that it’s just not recognizing or finding the printer. I find a lot of users don’t understand how to go through the cups http://localhost:631 and using root and passwod to set up the printer this way.

1 Like

Maybe they shouyld use system-config-printer - and be PERSISTENT. I have found that it SAYS it can’t find the driver you just installed… but on the final dialog, it is one of the choices offered to set as default. I have seen this several times with brother- dcp7060d from the AUR, and it always ends up working fine, without needing to resort to localhost:631.

Jes’ sayin’… :grin:

Oh - and note on the dates of printer drivers… if the printer hasn’t changed enough to need a new model number, then the driver doesn’t need any changes either! If the date of the driver is somewhere near the date you got the printer, you’re OK.

No error per sae. Print jobs hang saying no connection.

The exact message(s) would help go further.
Also journal log should help to find the issue.

Didn’t have a look, what printer it is exactly. How is it connected? Maybe firewall problem? What about group lp?
Only two things coming to my mind when it’s up to printer problems.

printer is connected via usb or over network?
I need to select the IP manually for my Brother wifi connected like that:
And do not take the network printers it finds automatic, so adding uri and then select drive manually is working here every time.

I have it as network ipp: It is configured correctly and works on two other Arch bades systems. Jist NOT on Endevour or Arch itself. NO ERRORS. Job hangs in the que constantly looking for printer until I manually delete the job. Printer is INSTALLED and shoes that it is in CUPS and on system-config-printer. ipp://

Something isn’t right or it wouldn’t hang. If it’s working on two other Arch based systems then it should work here. Maybe try removing the printer remove cups and reinstall cups.

sudo pacman -S cups cups-filters cups-pdf system-config-printer --needed

Then try setting it up again as something might be messed up with cups.

1 Like

I had these issues too with my Brother printer. Just tried every protocol until I got a working printer. Once it’s set up it works fabulous.

Also don’t forget to add all required packages.
These are obvious:

  • cups
  • cups-filters
  • libcups
  • python-pycups

But I needed pacman -S cups-pdf for mine to be identified and work (which I didn’t find very intuitive).

Protocol wise this is what worked best for me (fastest response time):

You can close this out. I am going to install Manjaro as the printer works flawlessly on it. Endeavour is a really nice distro, but I need a distro where everything works, especially my printer. I heard the people at Arch are betting against you folks and I hope you prove them wrong.

Closed at the request of the OP.