Can't exec bash scripts in one of my hard drives

Okay so I have a weird problem that I don’t really know how to solve :
I can’t launch a game (via a .sh script) on my HDD, but I can launch it if I move the game files to an external drive.

Here’s what happens when I try to launch:

[me@me-custom SnootGame-Update7_Fangsgiving-linux]$ sudo bash ligne 61: /mnt/HDD/VN/SnootGame-Update7_Fangsgiving-linux/lib/linux-x86_64/SnootGame: Permission non accordée ligne 61 : exec: /mnt/HDD/VN/SnootGame-Update7_Fangsgiving-linux/lib/linux-x86_64/SnootGame : impossible d'exécuter : Permission non accordée

(the error is permission denied)

I searched for help on internet and other forums, and found that the problem was likely due to my HDD being mounted with a “noexec” parameter. It didn’t appear in my fstab but I still tried to switch to exec, hoping that it would solve the problem. However, despite the option, it still doesn’t let me execute the game.
Here’s what my fstab line looks like for the HDD:

# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=F0125487125454A6                     /mnt/HDD       ntfs-3g defaults,exec,uid=1000,gid=1000,dmask=022,fmask=133 0 0

oh shit it’s the fmask isn’t it? I copy/pasted something someone gave me to do that mount and didn’t realize these options were the permissions. Problem solved I guess

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.