Can't enable Bluetooth

I have a tp-link UB400 adapter which I think is being detected, lsusb lists something named “Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)” - this disappears when it’s unplugged. When I enable Bluetooth in settings it doesn’t seem to actually enable it, the switch will be green until I open settings again, but it tells me Bluetooth is off and never shows the ‘devices’ window, rfkill shows bluetooth as unblocked.

Welcome to the forum!

Please take a look at this:

TL;DR, run in the terminal:

sudo pacman -S --needed bluez bluez-utils pulseaudio-bluetooth
sudo systemctl start bluetooth
sudo systemctl enable bluetooth
1 Like

bluez was already up to date, after running systemctl start/enable bluetooth it now seems to be searching for devices, however, it does so whether the adapter is plugged in or not, and never finds any actual devices to connect to.

Try a different usb port; make sure it is usb 2.0, if possible one at the mainboard backplane.
Some usb devices are picky about that.

check if your kernel 510 have a fix on this
https://bugs.archlinux.org/task/69110

give some info:
systemctl status bluetooth

lsusb >> log.txt && journalctl -b -0 >> log.txt && cat log.txt | curl -F 'f:1=<-' ix.io
1 Like