Can't do some things after wake up from suspend/hibernate when laptop is plugged into docking station

After wake up from suspend/hibernate, I can’t do:

Restart services or reboot pc and f.e. audio doesn’t work

when laptop is plugged into docking station.

These things start to work after unplug and plug docking stations from laptop.

I have Dell laptop and Dell WD19 docking station.

Please give me some advises. I come from Manjaro - I don’t think I had these problems.

Power saving utilities installed?

Welcome to the forum @wennaspeedy :partying_face::tada::balloon:

I am only using TLP. I tried disable it, but problem continues.

Creates lots of problems.

How did you disable it?




I believe the author of tlp recommends:

sudo systemctl mask tlp && sudo systemctl mask tlp-sleep.service

Reboot, then test for improvement.

If there is no improvement, then enable tlp again with the following command:

sudo systemctl unmask tlp && sudo systemctl unmask tlp-sleep.service

Then restart.

I tried it uninstall completely and no difference.

If your dock’s firmware can be updated, be sure it is up to date.

Perhaps testing an alternate kernel would be a good troubleshooting step as well.

Dock’s firmware is up to date.

Yes, you are right with the kernel.

It seems troubles are gone with LTS kernel. Bad for me, I like last 5.16 (or same ZEN) because of great performance.

The kernel regression will hopefully be corrected before too long.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.