Can't detect USB pen drives :v

Hello everyone, and congratulations on this new OS. I was running Manjaro previously (and I have some but not much experience distro hopping) and EndeavourOS is such a breeze to use.
However, I have encountered a problem I’ve never had before and a quick search on Google and the Arch Wiki haven’t helped.
Basically, my pc can’t find USB pen drives. I’ve tried connecting other things (such as my phone) and it gets recognized pretty easily, but neither my pen drives or my external HDDs are found.
Any help appreciated :slight_smile:

What does lsusb show? You can also plug in a usb drive & try udisksctl status. Just want to see if it sees the devices first.

It seems to be working now for some reason :thinking: not sure what I did to fix it, because rebooting didn’t work when I tried…Could it have been the daemon that was down?
Anyways here’s the output you’ve requested (and probably don’t need anymore):

lsusb                                                                                                                                sex 02 ago 2019 14:42:12 WEST
Bus 003 Device 002: ID 8087:8001 Intel Corp. 
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:8009 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 003: ID 1058:1078 Western Digital Technologies, Inc. Elements Portable (WDBUZG)
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 005: ID 046d:c332 Logitech, Inc. G502 Proteus Spectrum Optical Mouse
Bus 002 Device 004: ID 1e71:170e NZXT 
Bus 002 Device 003: ID 046d:0826 Logitech, Inc. HD Webcam C525
Bus 002 Device 002: ID 045e:0719 Microsoft Corp. Xbox 360 Wireless Adapter
Bus 002 Device 006: ID 2516:0059 Cooler Master Co., Ltd. 
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
udisksctl status                                                                                                                     sex 02 ago 2019 14:43:43 WEST
MODEL                     REVISION  SERIAL               DEVICE
Samsung SSD 840 EVO 250GB EXT0BB6Q  S1DBNSBDB31393L      sda     
WDC WD1003FZEX-00MK2A0    01.01A01  WD-WCC3F4PDEXJ8      sdb     
WDC WD7500BMVW-11AJGS3    01.01A01  WD-WXH1E8592HSM      sdc   

I recommend that you go into Applications > Settings Manager > Desktop > Icons and scroll all the way down. You will see Default Icons but not every option shows. You must scroll down in Default Icons until you see Removable Icons and activate that option. Then any connected external drive(s) will appear on your desktop.

You also should go into Applications > Settings Manager > File Manager > [Select the tab} Advanced. Make sure that Enable Volume Management is checked and then click on Configure the management of removable drives, devices and media.

Under Removable Storage check (activate) the first three options (Mount …, Mount…, Browse … ),

The above two steps should ensure that your external devices mount automatically and correctly and that you’ll be able to see that they actually are mounted.

Please note that all of the above applies only to the Xfce Desktop Environment.

I hope that this helps you.



I’m on Gnome, and the devices really weren’t connected, but the issue seems to have resolved itself somehow :slight_smile: thanks for the help :smiley: I will change the title of the post :slight_smile:

This looks like not rebooted after kernel update…

1 Like