Can't copy/paste into recently formatted Ext4 external SSD

Greetings lovely community,

I have a Seagate 2TB SSD I use for my backups. Its filesystem was just the default when I bought it, so exFAT (version 1.0). Today I decided to change that and I used Gnome Disks to format the 2TB drive to change it from exFAT to Ext4 with LUKS encryption. Gnome Disks formatting is pretty straight forward and there were no issues or errors setting it all up. However, when I plug in the newly formatted Ext4 2TB drive, my system asks me for the LUKS password which I enter and is accepted and when I try to add/copy/paste files using Nautilus to the drive I’m unable to do so. When I right click and check the properties of the drive, it shows it as root, but it says I’m not the owner so I don’t have any read/write privileges. I was the owner of the drive before I formatted, so I’m not sure why I’m not still the owner when I was the one that formatted it. But I don’t use external drives all that much, so this is my first time running into this issue.

Basically what I want to do, is take my exFAT SSD, format it to Ext4 with LUKS encryption and use it to copy/paste my backups. Somehow I have failed in this simple yet elusive task, so I come to this lovely and wise community for help and guidance. Feel free to ask me to paste any terminal outputs, because I honestly don’t even know where to begin. Anything drive related I’ve only ever used Gnome Disk or GParted and even then my knowledge and experience is very basic at best. I appreciate any help in getting my external drive functioning the way I want it to.

I have another identical 2TB SSD drive as well that I use for my photography work which I have not formatted and still uses exFAT and for that drive I can still access it and copy and paste anything I want with it.

To the mods: feel free to change my title to more articulately reflect the issue since I wasn’t 100% sure how best to say it.


1 Like

When you format it, you erase all the permissions. All you need to do is give yourself permissions to solve this issue.

sudo chown -R user:user /mnt/media/scott

Replace both users's with your actual username.

Two things:

  • exFat doesn’t actually have those permissions so you weren’t the owner before. It just looked like you were due to the mount options.
  • You probably didn’t format it as your user account. Accessing the underlying device to format it would normally require root permissions. If gnome disks didn’t ask for a password to do that, you must have some polkit rules allowing it.

Lastly, for someone like you, who likes to understand things, using gnome disks for these operations is probably a mistake. The nice thing about gnome disks is it “just works”. However, it is abstracting what it is really doing so you don’t get to have an understanding of it. For example, if you had mounted that exfat drive yourself, you would have realized how the permissions were being set.

7 Likes

That’s basically why I used Gnome Disks in this case since I’ve known it to “just work” for me. Should I go ahead and try your sudo chown -R... suggestion OR, (now hear me out!) should I try something else entirely!? You appear to be hinting that I could be going about this in a more terminal-centric or Arch type of way to set up this external drive properly. And if that’s the case, I’d be all about trying that option out simply for the learning experience. If there’s another way to format an external SSD drive with LUKS that keeps my permissions I wouldn’t mind giving that a try.

1 Like

No, you just need to assign the permissions as I showed you above.

Once you do that it should work fine going forward.

You didn’t really doing anything wrong, you just missed a step.

1 Like
[scott@endeavourOS ~]$ sudo chown -R scott:scott /mnt/media/scott
chown: cannot access '/mnt/media/scott': No such file or directory
[scott@endeavourOS ~]$ 

Should it be /run/media/scott instead or?

Yep. I am on my phone and I misread it

1 Like

This is the solution that worked for me, courtesy of @dalto 's #2 post

[scott@endeavourOS ~]$ sudo chown -R scott:scott /run/media/scott
[sudo] password for scott: 
[scott@endeavourOS ~]$ 

I didn’t see any output from the command, I know that’s normal so since the command returned no errors so I can only safely assume that did the job! Now I plugged/unplugged the drive in and out a few times (safely of course!) to make sure it works properly now. I think it didn’t work properly once, but I’ve done it a handful of times since then and I think it’s safe to say it’s in working order and I’m able to read/write files to the external drive now. This did get me wondering if Nautilus is 100% onboard with playing nice with encrypted external drives or if perhaps there’s a looming bug somewhere, but that’s more than likely a story for another day!

No worries man, our eyes play tricks on us sometimes :stuck_out_tongue:
Appreciate the help yet again. I know it was something relatively simple, but it’s good to know for when I attempt to format my other drive over to Ext4 too, so I’ve gained the knowledge passed down to me. Hopefully I can help someone like myself in the future!

I take this as a compliment, it made my night, thanks for noticing my efforts to try to learn what I can about EndeavourOS and the Arch system; you’ve been a worthy teacher so far! :wink:

6 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.