Cant connect to wifi, wifi-menu shows wifi + ip link works

Got most of my system configured and set up, really happy with the distro its been amazing. Installed with with no DE, running bspwm etc. Though last thing i have problems with is wifi-menu is not working. I’ve tried the following:

Disable NetworkManager.service
set my wlan0 to down
Make my own netctl wireless-wpa config

wifi worked just fine under the installer.

System: Legion y530, intel Wireless-AC 3165

1 Like

What’s this?


Maybe because Network Manager was running? :wink:

1 Like

He must mean the menu that comes from launching nm-applet?

I too am confused why he disabled the service? Perhaps he means for troubleshooting he turned it off then on again?

OP - This may help


Cause a few looks around the arch wiki’s etc. due to conflict with netctl, networkmanager service had been turned on and off like odiouslmp said. im not stupid . Wifi-menu is a tui for netctl that came with endeavour as far as i can see, instead of making config files in /etc/netctl/


Thanks! it worked

1 Like

I’m not sure I did much! But your’r welcome! :grin: