Can't connect to the internet(Not on Live USB or on actual installation)

I have a huge problem. I can’t connect to wlan0, my WiFi, whether on my Live USB or on the actual installation itself. Strangely, I could connect to the internet using iwctl on Arch Live USB, but not on EndeavourOS for some reason, even though EndeavourOS is literally just Arch on easy mode, so anything Arch will apply here, right? Because I coudn’t connect to the internet on my Live USB, I was forced to install Endeavour OS with the offline method with XFCE and Endeavour OS theming. When I tried ip link, it only showed the ‘lo’ connection and the ethernet port. No ‘wlan0’, which means Endeavour can’t recognise my router. It should be noted that I am pretty new to this. The only way I’m forced to connect to the internet on Endeavour OS is through iPhone USB tethering and that’s annoying. Any help is appreciated. TY

welcome at the forum :enos:
To see what is the issue it would need at least any info about teh hardware…
inxi -Fxxc0z

Sorry for replying late, anyways this was the output of the command:

  Kernel: 6.2.6-arch1-1 arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    Desktop: Xfce v: 4.18.1 tk: Gtk v: 3.24.36 wm: xfwm dm: LightDM
    Distro: EndeavourOS base: Arch Linux
  Type: Laptop System: Apple product: iMac18,1 v: 1.0
    serial: <superuser required> Chassis: type: 9 v: Mac-4B682C642B45593E
    serial: <superuser required>
  Mobo: Apple model: Mac-4B682C642B45593E v: iMac18,1
    serial: <superuser required> UEFI: Apple v: 451. date: 04/11/2022
  Device-1: apple_mfi_fastcharge model: N/A serial: N/A charge: N/A
    status: N/A
  Info: dual core model: Intel Core i5-7360U bits: 64 type: MT MCP
    arch: Amber/Kaby Lake note: check rev: 9 cache: L1: 128 KiB L2: 512 KiB
    L3: 4 MiB
  Speed (MHz): avg: 400 min/max: 400/3600 cores: 1: 400 2: 400 3: 400 4: 400
    bogomips: 18406
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Device-1: Intel Iris Plus Graphics 640 vendor: Apple driver: i915 v: kernel
    arch: Gen-9.5 ports: active: eDP-1 empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2
    bus-ID: 00:02.0 chip-ID: 8086:5926
  Device-2: Apple FaceTime HD Camera (Built-in) type: USB driver: uvcvideo
    bus-ID: 1-3:3 chip-ID: 05ac:8511
  Display: x11 server: X.Org v: 21.1.7 compositor: xfwm v: 4.18.0 driver: X:
    loaded: modesetting alternate: fbdev,intel,vesa dri: iris gpu: i915
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96
  Monitor-1: eDP-1 model: Apple iMac res: 1920x1080 dpi: 103
    diag: 545mm (21.5")
  API: OpenGL v: 4.6 Mesa 22.3.6 renderer: Mesa Intel Iris Plus Graphics
    640 (Kaby Lake GT3e) (KBL GT3) direct-render: Yes
  Device-1: Intel Sunrise Point-LP HD Audio driver: snd_hda_intel v: kernel
    bus-ID: 00:1f.3 chip-ID: 8086:9d71
  Sound API: ALSA v: k6.2.6-arch1-1 running: yes
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.67 running: yes
  Device-1: Broadcom BCM43602 802.11ac Wireless LAN SoC vendor: Apple
    driver: N/A pcie: speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0
    chip-ID: 14e4:43ba
  Device-2: Broadcom NetXtreme BCM57766 Gigabit Ethernet PCIe driver: tg3
    v: kernel pcie: speed: 2.5 GT/s lanes: 1 port: N/A bus-ID: 03:00.0
    chip-ID: 14e4:1686
  IF: enp3s0f0 state: down mac: <filter>
  IF-ID-1: enp0s20f0u1c4i2 state: up speed: N/A duplex: N/A mac: <filter>
  Device-1: Apple Bluetooth USB Host Controller type: USB
    driver: btusb,hid-generic,usbhid bus-ID: 1-9:6 chip-ID: 05ac:8296
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: see --recommends
  Local Storage: total: 931.51 GiB used: 5.52 GiB (0.6%)
  ID-1: /dev/sda vendor: Apple model: HDD HTS541010A9E632 size: 931.51 GiB
    speed: 3.0 Gb/s serial: <filter>
  ID-1: / size: 722.92 GiB used: 5.33 GiB (0.7%) fs: ext4 dev: /dev/sda4
  ID-2: /boot/efi size: 196.9 MiB used: 128.4 MiB (65.2%) fs: vfat
    dev: /dev/sda1
  ID-1: swap-1 type: partition size: 2 GiB used: 72.2 MiB (3.5%) priority: -2
    dev: /dev/sda5
  System Temperatures: cpu: 25.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 298 Uptime: 16h 7m Memory: 7.63 GiB used: 2.27 GiB (29.8%)
  Init: systemd v: 253 default: graphical Compilers: gcc: 12.2.1 Packages:
  pm: pacman pkgs: 793 Shell: Bash v: 5.1.16 running-in: xfce4-terminal
  inxi: 3.3.25

The reason you’re seeing Apple Mac as my host is because I’m dualbooting Endeavour OS and MacOS, just to let you know.

please use code tags…

could be you have to remove broadcom-wl package.

can work on live usb too

sudo pacman -R broadcom-wl-dkms
sudo rmmod wl
sudo modprobe brcmfmac
sudo systemctl restart NetworkManager

wait should I run the thing again but with root?

it worked tysm. I rlly appreciate the help.

was my guide :wink:

Alr, but Ihave another problem. iwctl doesen’t work. When I try running it, it says ‘Waiting for IWD to start…’ but when I write ‘sudo systemctl start iwctl’, it says: ‘Failed to start iwctl.service: Unit iwctl.service not found.’ Strange.

we have NetworkManager enabled by default… not sure if they can be used side by side?
NetworkManager ships with nmcli and nmtui plus it is integrated in almost all DEs

Why do you need iwd? As @joekamprad said :enos: already has network manager. According to Arch WiKi, one can use iwd and any other network manager side by side. But why?

but i bet you can not use them both enabled at the same time…
And i bet user is simply only try to find the tool to setup wiereless connection and stumble over iwd…

Yeah, can’t have two wives in the same kitchen :stuck_out_tongue:

Only a problem if they’re both yours?? :duck:

Well, one would be current the other would be my used-to-be current. (hypothetical, I’m still single.)

There are those who contend that the hypothetical kind of wife is the BEST kind…

Nope - not going there!

1 Like