Can't connect to local server in default firefox

my local server is running. I can connect to it fine on every other device. I am on the right network.
But when I try to open it in firefox in EndeavorOS it just says Server Not Found. I ended up reinstalling for unrelated reasons and on the fresh install it still doesn’t work.
I have set the network to trusted on firewall.
quick note: Whilst I am new to EndeavorOS, so far I really like it. great job

Open the port in the firewall, in the permanent section.

sorry if I’m being an idiot, but my server is using Umbrel so I usually just type in server.local/
I don’t know which port to open

Check if you don’t have DNS over HTTPS enabled in Firefox.

1 Like

OK, to test if it is the firewall:

 sudo systemctl disable firewalld.service 

Then reboot and try to access.

Why not just do sudo systemctl stop firewalld.service and skip the reboot part?

1 Like

I have tried that and it still doesn’t work

Can you ping the server’s address?

As I said, check for DNS over HTTPS, Firefox defaults to that and ignores system DNS, so it doesn’t see local addresses.

From the command line.


As an example (base address of my router).

it works. It brings up my router’s page when I go to it in browser as well.
I have disabled dns over https

So what is the ip address of your server?

Try getting info from FF console.
In a new tab, Ctrl+Shift+i (dev tools), click Tab Console (or Debug/Errors something).
Type the IP in address bar and press Enter.
Look for relevant error messages in Dev tools Console(s).

That’s strange. When I type in the ip it connects fine. But i’d like to be able to type in the URL as I can on every other device, so is there a way I can do that?

EDIT: also when i go to the nextcloud it says access from untrusted domain but I don’t know what my domain is to add it to trusted
EDIT 2: I thought it would always be same domain because I only connect to it and have it available on the local network I thought.
EDIT 3: So it’s connecting as if I was external. but why?

Do you read all posts that try to help you?
If so, answer on their suggestions. :person_shrugging:

I did check, it wasnt enabled anyway. I should have mentioned þat.

1 Like

Check with other browsers, to eliminate being a system issue.

It just appears to have suddenly started working. What could have caused this?!?!
ah well at least it works now