Can't connect to home wifi network, changed home , same issue

Hello,
I’ve been using endeavourOS for some time now and everything has been ok.
I’m new to Arch Linux and to Linux in general, however I didn’t face network problems ‘till now.
Before some days , when I booted to linux , as always , my home wifi didn’t show up (all my neighbors’ wifi did). I thought this was just a usual bug, so I tried a 60s reboot (I shut down and wait 60s before booting). Same issue. Didn’t bother to solve and just used LAN since after 3 days I would move to a new house.
Right now I am at my new house and guess what - my home wifi doesn’t show up. I tried rebooting, same issue. Updated the system, same issue. So I thought this:
I restarted router and waited. My home wifi then showed up and I could connect to it. After 1m or so , it disconnects and disappears from wifi list. Still, I can see the neighbors’ wifi but not mine.
I tried to restart wifi again and check, same issue. I ran journalctl -f command and this was the output for network manager if this is useful :

```Oct 30 17:56:56 das-workshop NetworkManager[550]: <info>  [1667149016.2880] device (wlan0): set-hw-addr: set MAC address to 42:53:2C:D4:1B:A8 (scanning)
Oct 30 17:56:56 das-workshop NetworkManager[550]: <info>  [1667149016.3273] device (wlan0): supplicant interface state: inactive -> disconnected
Oct 30 17:56:56 das-workshop NetworkManager[550]: <info>  [1667149016.3333] device (wlan0): supplicant interface state: disconnected -> inactive
Oct 30 17:58:47 das-workshop dbus-daemon[521]: [system] Activating service name='org.kde.powerdevil.backlighthelper' requested by ':1.37' (uid=1000 pid=839 comm="/usr/lib/org_kde_powerdevil") (using servicehelper)

Also after disconnecting, this notification shows up :
authorization supplicant timed out
and some times this :
...couldn't find network
I also observed that from time to time my home networks shows up with a 30% signal strength (my 5GHZ one doesnt show up).
I am trying another 60s reboot as I finish this.
If you can help, I would be grateful. I can assist with any information you need.
Thanks.

Welcome to the forum! :smile:

That sounds like a router problem.
Or maybe the location of the router is too far or behind heavy walls from your machine?

Do your other devices, like a phone or tablet or another computer see the same issue? If they do, then it definitely is a router problem.

Thanks!

My iPhone , my dad’s iPhone and all other phones can connect with no problem and a 100% signal strength. No problems at all with other devices. My sister’s macbook can connect easy as well.
I could try to live boot in a live endeavourOS if I can or in another live OS from arch distro.
Until that , any other idea?

First of all what is the WiFi chip?

inxi -Na

here it is :

  Device-1: Intel 82579LM Gigabit Network vendor: Dell driver: e1000e
    v: kernel port: 4060 bus-ID: 00:19.0 chip-ID: 8086:1502 class-ID: 0200
  Device-2: Broadcom BCM43228 802.11a/b/g/n vendor: Dell Wireless 1530
    Half-size Mini PCIe Card driver: wl v: kernel modules: bcma pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 14e4:4359
    class-ID: 0280

edit : my system is up to date , and so are the drivers. some other guy suggested to me that it could have been a regdomain problem so I used iw reg set AL since AL is the code for the country I live on ( Albania ), but didn’t work.

Do you have broadcom-wl-dkms installed?

Ok, so the router seems to work. Your card supports Wifi 4, so you might want to check if the router is set to support that as well.

Another idea is the wl driver might be the problem. Can you show the output of

pacman -Ss broadcom wl

Edit: sorry I meant command

pacman -Qs broadcom wl

https://wireless.wiki.kernel.org/en/users/Drivers/b43

Edit:

14e4:4359 	yes (3.17+) 	BCM43228 	a/b/g/n 	N (r16) 	wl 

Yeah, it should be supported.

1 Like

https://wiki.archlinux.org/title/Broadcom_wireless

yes, I do. But if you know how , can you tell me how to remove this package and reinstall just in case?
I update the os regulary and I have seen that package update as well , so I don’t that that’s neccessary but just in case

ofc :

local/broadcom-wl-dkms 6.30.223.271-35
    Broadcom 802.11 Linux STA wireless driver

it works I believe ?