Cant connect to brother MFC-J650DW printer

I cant get endaevor to connect to my brother MFC-J650DW printer. I did everything in the MrRoberts’ solution of Cups - server error but I still can’t get my printer to work. when using system-config-printer I get “there was an error during the CUPS operation: ‘server-error-internal-error’.”

I am not good with printer driver stuff (like not at all) but I see there is a driver package in AUR for your printer:

Have you already installed it?

yeah I have.

1 Like

sudo gpasswd -a username sys

Another thing I came to think of: you need to reboot or log out and log back in for your user to be added to a group. Perhaps you have already. In that case, running out of ideas, I shall withdraw :blush: :innocent:

I restarted after adding my account to the user group too.

1 Like

check to see if cups and cups-pdf are installed:

pacman -Q | grep cups

If cups and cups-pdf are not listed in the output, install them with pacman and use systemctl to enable cups
sudo systemctl enable cups.service

if cups and cups-pdf were already installed use systemctl to check the status of cups.service
sudo systemctl status cups.service
it should say cups is active. If not use systemctl to enable cups.

Next, in your favorite browser, enter the following in the URL entry box.
localhost:631
and it should connect you to the cups server.

If you don’t get the cups server, then cups is not up and running.

If cups is up and running, my suggestion is to use the cups server to install your printer.

Pudge

1 Like

I checked and I did have cups and cups-pdf installed, I ran “sudo systemctl enable cups.service” just in case and got this weird message “Unit /usr/lib/systemd/system/cups.service is added as a dependency to a non-existent unit printers.target.” I get the cups server with localhost but how do I add a printer with cups server? Sorry for replying so late I had to do something.

@sheast21
Is the printer hooked up to usb?

No its a network printer.

So i assume you installed the package from the AUR? You should be able to add a network printer from http://localhost:631

2 Likes

That worked thank you! Even the scanning works!!!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.