Can't connect my bluetooth headphones

I’m trying to connect my Beats Studio³ Wireless to my PC, I’m using Blueberry and I’ve tried Blueman.
I ran, sudo systemctl start bluetooth then ran sudo systemctl enable bluetooth and tried to connect them and it didn’t work, so then i tried to restart to see if that would fix it and it didn’t.
Any ideas on how to fix this?

What is the output of systemctl status bluetooth.service?
I enabled it using systemctl start bluetooth.service and systemctl enable bluetooth.service.

bluetooth.service - Bluetooth service
Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
Active: active (running) since Sat 2020-04-18 20:46:27 CDT; 23min ago
Docs: man:bluetoothd(8)
Main PID: 935 (bluetoothd)
Status: “Running”
Tasks: 1 (limit: 38411)
Memory: 6.4M
CGroup: /system.slice/bluetooth.service
└─935 /usr/lib/bluetooth/bluetoothd

Apr 18 20:46:27 Router systemd[1]: Started Bluetooth service.
Apr 18 20:46:27 Router bluetoothd[935]: Starting SDP server
Apr 18 20:46:27 Router bluetoothd[935]: Bluetooth management interface 1.15 initialized
Apr 18 20:46:54 Router bluetoothd[935]: Endpoint registered: sender=:1.49 path=/MediaEndpoint/A2DPSink/sbc
Apr 18 20:46:54 Router bluetoothd[935]: Endpoint registered: sender=:1.49 path=/MediaEndpoint/A2DPSource/sbc
Apr 18 20:49:36 Router bluetoothd[935]: Unable pair since another pairing is in progress
Apr 18 20:49:42 Router bluetoothd[935]: Unable pair since another pairing is in progress
Apr 18 20:49:43 Router bluetoothd[935]: Unable pair since another pairing is in progress
Apr 18 21:06:41 Router bluetoothd[935]: Pair device timed out for hci0
Apr 18 21:07:57 Router bluetoothd[935]: /org/bluez/hci0/dev_F8_DF_15_D7_41_90/sep1/fd0: fd(164) ready

I just answered this in another thread:

I got a bluetooth card for my Dell E6400 Laptop and I added all the Bluez stuff per the Wiki and still could not get it to work until I found this article on the Arch forum and at the end the person said to fix most of the bluetooth issues he was having was to also install “bluez-hid2hci” he also stated it should be part of the Bluez master package… (Their words)
You might also look at the Arch post…

So installed that package and all my bluetooth issue were fixed. Blueman could see my speakers… Not sure that this will help you but there it is for ya to try… Good Luck :alien:

1 Like

Interesting… while I was able to pair to a JBL 3 Charge speaker, the Beats Studio 3 still won’t connect.
i’m thinking it has to be something specific to the Beats Studio headphones

[bluetooth]# info 44:18:FD:C6:DF:49
Device 44:18:FD:C6:DF:49 (public)
Name: Headphones
Alias: Headphones
Class: 0x00240418
Icon: audio-card
Paired: no
Trusted: yes
Blocked: no
Connected: no
LegacyPairing: no
Modalias: bluetooth:v004Cp2009d0244

Failed to pair: org.bluez.Error.AuthenticationCanceled

do you try with cli bluetoothctl as root?

sudo bluetoothctl
power on
agent on
scan on
pair 00:1D:43:6D:03:26

replace 00:1D:43:6D:03:26 with the one for your device

trust 00:1D:43:6D:03:26

connect 00:1D:43:6D:03:26

1 Like

I am glad to inform you all that my Bluetooth speaker (local make) working fine after installing following

sudo pacman -S --needed bluez bluez-utils
pacman - S blueberry

1 Like

And enabled the service with:
sudo systemctl enable --now bluetooth


Thanks to all who contributed for the help, it’s nice to have wireless connectivity to my headphones once more :sweat_smile:. This Bluetooth thing has been an issue for me since switching to EndeavourOS about 6 weeks ago. And, after purchasing a new set of headphones I Was determined to get it fixed. Again, thanks and God bless.