Can't change brightness in endeavour os

so i just reinstalled endeavourOS to change my WM into i3-wm

and i can’t change the brightness, i have faced this issue before in endeavourOS KDE but i remember i only have add acpi_backlight=video

so i tried to fix it
first, i installed brightnessctl and tried to use it’s command like brightnessctl s 3

It outputs :
Updated device ‘nvidia_wmi_ec_backlight’:
Device ‘nvidia_wmi_ec_backlight’ of class ‘backlight’:
Current brightness: 3 (1%)
Max brightness: 255

But nothing changed, my screen is still in max brightness

then i tried putting every one of these into /etc/default/grub

then i sudo grub-mkconfig -o /boot/grub/grub.cfg
reboot, tried changing the brightness again and nothing changed

my backlight folder name is nvidia_wmi_ec_backlight

can someone help me fix this issue? thankyou

A lot of folks have issues getting this going on i3 for some reason. It seems different things work for different folks; if you read through some of the other solutions in the forum you are bound to find something that works for you.

Here are some relevant threads I found with a quick search:

It’s just a matter of doing some testing to figure out what works in your specific setup.

For me, adding this to the config works:

bindsym XF86MonBrightnessUp exec brightnessctl -c backlight set +5%
1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.