Can't boot to Linux properly after dual booting windows

(edit: I deleted the partitions as instructed on the last reply/8, tried all I could, didn’t succeed. In the end, I deleted them again after the re-installation of windows, and EOS boots fine now.)

Greetings, EOS Community.

I wanted to dual boot windows, so I resized my main disk using gparted. I installed windows on the new partition, and it made a few more partitions, and turned the main one to NTFS. After successfully installing windows, I changed the boot stuff accordingly, firstly with bcdedit on windows, then I confirmed it was good for bios and, it would bring me to my Linux bootloader on startup. However, when trying to boot to EOS, it fails to start file system check on /dev/by-uuid/2ebefd1f-5007-489d-96d3-b050f9b1ffc
Along with dependency fails for /sysroot, initrd file system, and mountpoints configured in real boot, and it brings up an emergency shell.
I tried following some fixes from other similar issues related to fstab, tried using /dev/EOSpartition rather than it’s uuid. I also believe there are 2 partitions with the same uuid now so that may be the reason it fails. I would also like to note that I tried chrooting to the partition and everything is still there, thankfully and so, I don’t know what else to do to fix this.

I also use systemd

Could you boot up your EnOS’ live usb and post the output of the following commands?

lsblk -f

sudo parted -l


Here you go

[liveuser@eos-2023.05.28 ~]$ lsblk -f
NAME        FSTYPE   FSVER            LABEL       UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
loop0       squashfs 4.0                                                                     0   100% /run/archiso/airootfs
├─sda1      exfat    1.0              Ventoy      8D0B-827E                                           
│ └─ventoy  iso9660  Joliet Extension EOS_202305  2023-05-28-11-02-36-00                     0   100% /run/archiso/bootmnt
└─sda2      vfat     FAT16            VTOYEFI     1E1C-88C8                                           
├─nvme0n1p1 vfat     FAT32                        E7C9-43C1                                           
├─nvme0n1p2 ext4     1.0              endeavouros 2ebefd1f-5007-489d-96d3-b050f9ab1ffc                
├─nvme0n1p3 ntfs                                  740A03AC0A036A86                                    
├─nvme0n1p4 ext4     1.0              endeavouros 2ebefd1f-5007-489d-96d3-b050f9ab1ffc                
└─nvme0n1p5 swap     1                swap        66428c42-d59c-4a23-b344-bb337c06b03f                
[liveuser@eos-2023.05.28 ~]$ sudo parted -l
Model: SanDisk Cruzer Blade (scsi)
Disk /dev/sda: 16.0GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  16.0GB  16.0GB  primary               boot
 2      16.0GB  16.0GB  33.6MB  primary  fat16        esp

Model: SKHynix_HFM512GDHTNI-87A0B (nvme)
Disk /dev/nvme0n1: 512GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system     Name                          Flags
 1      2097kB  1051MB  1049MB  fat32                                         boot, esp
 2      1051MB  1067MB  16.8MB  ext4            Microsoft reserved partition  msftres, no_automount
 3      1067MB  106GB   105GB   ntfs            Basic data partition          msftdata
 4      106GB   503GB   397GB   ext4            endeavouros
 5      503GB   512GB   9449MB  linux-swap(v1)                                swap

[liveuser@eos-2023.05.28 ~]$ efibootmgr
BootCurrent: 0004
Timeout: 0 seconds
BootOrder: 0000,0003,2001,2002,2003
Boot0000* Linux Boot Manager    HD(1,GPT,b10c2515-aa2a-4caa-ba1f-e39b4c941149,0x1000,0x1f4000)/File(\EFI\systemd\systemd-bootx64.efi)
Boot0001* EFI PXE 0 for IPv4 (8C-8C-AA-6F-D3-AB)     PciRoot(0x0)/Pci(0x2,0x1)/Pci(0x0,0x0)/MAC(8c8caa6fd3ab,0)/IPv4(,0,0)RC
Boot0002* EFI PXE 0 for IPv6 (8C-8C-AA-6F-D3-AB)     PciRoot(0x0)/Pci(0x2,0x1)/Pci(0x0,0x0)/MAC(8c8caa6fd3ab,0)/IPv6([::]:<->[::]:,0,0)RC
Boot0003* Windows Boot Manager    HD(1,GPT,b10c2515-aa2a-4caa-ba1f-e39b4c941149,0x1000,0x1f4000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)RC
Boot0004* EFI USB Device (SanDisk)    UsbWwid(781,5567,0,0302193112232218504)/HD(2,MBR,0xc9c0e35c,0x1dc0000,0x10000)RC
Boot2001* EFI USB Device    RC
Boot2002* EFI DVD/CDROM    RC
Boot2003* EFI Network    RC
[liveuser@eos-2023.05.28 ~]$ 

This is a bit confusing.
By the size of it, it cannot be your EnOS system partition.
By the filesystem (EXT4), it cannot be a Microsoft reserved partition.

Lets check the UUIDs in your fstab (I assume nvme0n1p4 is where EnOS resides):

sudo mount /dev/nvme0n1p4 /mnt


cat /mnt/etc/fstab

The 300gb one/0n1p4 is EOS and the 100gb one/0n1p3 is Windows

[liveuser@eos-2023.05.28 ~]$ sudo mount /dev/nvme0n1p4 /mnt

[liveuser@eos-2023.05.28 ~]$ cat /mnt/etc/fstab
# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=E7C9-43C1                            /efi           vfat    defaults,noatime 0 2
/dev/nvme0n1p4                            /              ext4    defaults,noatime 0 1
UUID=66428c42-d59c-4a23-b344-bb337c06b03f swap           swap    defaults   0 0
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0
1 Like
/dev/nvme0n1p4                            /              ext4    defaults,noatime 0 1

Alright, your system partition in fstab is referenced by disk id and not UUID so for now I don’t think the same UUID on two different partitions is a problem.

With your system partition still mounted at /mnt:

sudo mount /dev/nvme0n1p1 /mnt/efi

Now chroot into your system:

sudo arch-chroot /mnt

In chroot, run:


When it is done, type exit followed by enter to quit chroot.

Cross your fingers and reboot!

The command went fine, rebooted, unfortunately, I still get the same errors.

That is the odd partition I was wondering about:

This shouldn’t be marked as EXT4 if it is a Microsoft reserved partition.
And it has the same UUID as your EnOS’ system partition.

I don’t know how to fix such issue.

You could also try a filesystem check on your EnOS’ system partition from the live session and see if that helps.

If there are no better suggestions here on the forum, mine would be to reinstall Windows according to the following:

  1. In EnOS’ live session, launch Gparted and delete nvme0n1p2 and nvme0n1p3.
    Leave that space unallocated (do not format)
  2. Launch your Windows installer and point it to that unallocated space

Backup any data of value to you from EnOS’ partition first to be on the safe side if something goes wrong

1 Like

Just an Update: I tried dual booting windows again, of course, I got the same issues, but, I managed to fix it myself by chrooting into the boot entries (arch.conf). I modified the root= option to boot from the specific /dev/nvme0n1p4 partition rather than it’s UUID (which was the same for 2 separate partitions, for some reason), and now both EOS and Windows boot properly. I remember editing /etc/fstab, which didn’t work out, but here I am, for anyone else having this issue.

Have you tried changing the UUID of the partition? (you can do this with Gparted, or other utility)

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.