Cant boot system after nvidia downgrade / system upgrade

i use kde plasma x11 on acer nitro-v an515-54 laptop with gtx1160ti. nvidia drivers worked well up to 530 or 535 series (dont remember exactly) at which point the performance in aaa games became terrible but i continued using these drivers hoping it d be fixed in some upcoming update. after not upgrading my system for about month or two i did system upgrade with paru -Syu which upgraded the nvidia drivers to 545 series among others. with the problem still not being fixed i decided to use nvidia-all to downgrade the nvidia driver to version 525.89.02 which is the last version i remember working correctly. after this i can get to grub and choose which kernel i want to boot into and the booting process starts but never finishes on either kernel (i have lts and latest). i believe (for no reason in particular) that this is caused by one or multiple of the upgraded packages and not the downgraded drivers. i d also like to mention as i believe it might be somehow relevant that when upgrading regular nvidia drivers previously when dkms was doing its thing the non-lts kernel always exited with code 10 over the course of past few months (4+). i have no idea what that did if anything as i have generally no need to switch from lts kernel. sooo is there a way to change some grub settings or something among those lines so i can get back to my system without having to reinstall everything from scratch? if so how?

Thanks for all the help and overwhelming support!

sooo the way to get back into my system was not changing some grub settings. it was booting a live usb and using arch-chroot. i then uninstalled all packages with nvidia in their name (except nvidia-inst) using paru -Rs and installed the latest drivers using nvidia-inst --prime --conf --32. (i also deleted a bunch of files related to dkms previous to using nvidia-inst but i dont remember their location.) in the meantime i did my research and found out the thing that caused my problems was introduced in 535 series of the drivers. then i proceeded to use nvidia-all to downgrade to 530 series, which worked - in a sense that it didnt make my system unbootable - at least for the lts kernel, when dkms was doing its thing the non-lts kernel it exited with code 10 once again (as mentioned in original post). i tried to boot into non-lts kernel to check if i was able to and i wasnt. due to this i would like to stay on 6.1-lts kernel. for now i have simply added linux-lts and linux-lts-headers under IgnorePkg in /etc/pacman.conf. is there however a way to continue recieving patches for this kernel as the mainstream package will soon upgrade to 6.6-lts?

one thing i omitted from the original post is that before my system became unbootable i used nvidia-all to install/reinstall multiple versions of nvidia drivers and my system only became unbootable on 6th-7th attempt. based on this as well as the fact that using nvidia-all afterwards again worked for me to install the 530 series drivers i think its fair to assume the reason my system became unbootable was due to the 6-7 semi-random downgrades/upgrades. why did i do these 6-7 semi-random downgrades/upgrades when i claimed to remember that 525.89.02 had been the last version to work correctly? because it didnt work. after that i was just guessing. which is why i believed the problem (which i now recognise as 2 separate problems) was related to package upgrade. and it was. the second problem me and others have is that after recent update to steam client it no longer downloads or builds any shaders which leads to heavy stuttering while in game. see: