Can't boot on installer

I needed to install endeavour os again but this time the installer doesn’t even boot. I tried to switch to propretary drivers boot but it just skips it and i don’t have idea why. I tried doing the installer with etcher, popsicle, and on windows i tried with rufus and usbwriter. All of them don’t work.
Is there a way to fix this?
I don’t mind having the past iso if someone has it.

Edit: I think the problem was the kernel it loaded. When i finished everything i installed lts kernel and the same behaviour happened. Maybe this helps someone.

What is your drive partitioning, do you have any other distros or win11?

Did you try another USB drive?

What happens, specifically. Are you getting an error? Is it hanging at some point? If so, what is the last thing you see on your screen?

I see literally nothing. It doesn’t boot up to the live environment and during the logs and don’t see any error. And while selectiong the boot option there’s another for nvidia but i can’t even select it. There should be something wrong

Didn’t think of that

The first time someone has an issue booting the latest ISO hardly…
I would bet the issue is something related to burning ISO (but as you tried different ways…) more like something with the boot method and Firmware settings used?

Do you checked the ISO file before burning?

1 Like

I will download the iso from another mirror and verify the installation and to a format for the drive. If still then doesn’t work i guess i have to download other iso :frowning:

and do not use etcher it is known to cause issues with archiso …
rufus should work but make sure using dd mode

I tried your method but i ended up using the August iso with offline installer because online gave me an error. Probably some outdated link

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.