Can't boot into system after install

Hello, so this is my first time around with a Arch based distro. I followed the default installation process with the exception of partitioning( I kept my old /home from Mint)
Right after the installation, I restarted, booted into my internal HDD and here I am now,

Any help ? :sweat_smile:

Ok this is what the system is kinda explain :stuck_out_tongue:

Disk label is GPT :

its installed in legacy mode.

current it do now a reinstall with 1mb space on top cause of the gpt nature :

as follow was on this wiki on legacy & gpt , https://help.ubuntu.com/community/DiskSpace#BIOS-Boot_or_EFI_partition_.28required_on_GPT_disks.29

but stil not boot, sure need some more info properly dont know the current, before first encounter on telegram, the disk was not flagged also as boot

As I can see from the screen @ringo provided the boot partition isn’t properly formatted and therefore not recognised.
Is this an install next to another distro or did you wipe Linux Mint? The boot partition is also very small, increase it to 512 MB and use ext4 for it and flag it as boot.

Boot is in / , on ubuntu wiki because it is on gpt neer bios_grub flag that the 1mb partiotion we made / before as boot also failed

hello @ringo,

Have a look in this thread HERE for an exemple from Gparted partition scheme. Like @Bryanpwo told You, it comes from your boot EFI, resize it and add the boot esp flag from Gparted.

He got in legacy, probably want only in legacy

First question is what is on /dev/sda11 and where does it come from? there is data on it and it is more then a default sytem install, so may data partition with personal data or any old install system with home and files…

/dev/sda9 is some DELL Windows rescue leftover and /dev/sda2 and /dev/sda5 holds nothing inside 1.94GB are mostly the journaling files from ext4… so taking a look into my magic ball … it looks like user try to install system to /dev/sda11 and do not format it?

And gpt will not work in legacy mode also… only on EFI-Boot.
This will need to create a msdos partition scheme to have mbr available to write grub there…

Personal data needs to be backupped to another drive and disk erased. (IMPOV)
or change to EFI and try to keep /dev/sda11 untouched and remove all other partitions.

@joekamprad
Can you please explain how to create that msdos partition scheme ? I can’t actually wipe the whole HDD as i need the stuff inside /dev/sda11( it’s my /home from mint)

why is it that you want legacy boot then? as it looks like you have system with EFI before?
When you change partition scheme all data will be lost. So to do so you need to backup all files you want to keep from /dev/sda11 to another disk (BACKUP)

@Rasenkai It looks like your original install was in UEFI mode. I’m not sure how you created the live usb? You said you had Mint originally installed. /dev/sda9 is some recovery environment for Windows. Did you just have Mint on it then? If you need the original home partition then you better back it up first. You should be installing it UEFI mode not BIOS MBR. If you can please give an explanation of how you created your live usb and how you went about installing it as this would help. It is always helpful to understand where as user has gone wrong when attempting to install EndeavourOS.

Thanks.

You could have EndeavourOS in UEFI as well. It will be necessary to reorganise your partition scheme. First by security listen the magic Ball from @joekamprad and backup your sda11 142.89 GiB or don’t touch it or resize it. I put You below a scheme that will work for UEFI.

sda1 FAT32 Mount : /Boot/EFI Flag : boot, esp 550MB (550Mo is what The author of gdisk suggests which is 524,52Mio or 0,51Gio)

sda2 EXT4 Mount : / Flag : nothing 27.94Gio
(means 30Go for your system EndeavourOS)

sda3 EXT4 Mount : /home Flag : nothing 273,57Gio
(means 293,74Go for your Personnal Data, the value would be near from that maybe not exatly, extend the size at maximum until the start of your Swap)

To make it easier on Gparted :
1/ delete sda1
2/ delete sda2
3/ You will obtain an empty unknown space
Use it to create the partition scheme I show You up.
4/ install EndeavourOS on sda2 /
5/ After install, You could also access to your sda11 data to bring them to your new sda3 /home
6/ After this clean install, you could do what You want with the space from these partitions placed after your Swap which would be sda4.

@ricklinux
I used the default liveusb method mentioned on the EnOS site.
I had Mint and Windows on dual boot.
Currently trying UEFI mode rn

@FLVAL
Done, doesn’t work.

I’m following some probable solutions right now on the official Telegram community right now.
Someone suggested that manual partitioning might have some bugs.
I’ll be back here with some info later incase those work

Did You BACKUP your sda11 ? By security do it first of all…

When your partition scheme is done correctly on GParted, send it here and show us your partition table also in case…but remember, like @joekamprad told if You change your partition Table you will lost all data on your HDD, don’t forget it !

Manual partitions in Calamares has bugs, the manual partitioning with Gparted is universal as described in the wiki.
On Telegram you also informed about a self build kernel you build on your phone or something and transfered it to the installation?
This is what I mean with elaborate what you’ve done.

I’m taking a bit of a distance from this post, there so many communitymembers who are and want to help you. But you can’t expect a miracle if you don’t give all the information.

1 Like

Right, You could do it but give us the feedback to see your UEFI EndeavourOS to fly off. :rocket:

The OP is getting help on telegram and like we all said in here, the partition table was wrongly executed.

I applaud all your patience, thank you for being such a great supporting community, tbh I lost mine…

I have been doing everything by Gparted right now.
Also that kernel part has nothing to do with EnOS, it’s my Android kernel source that’s stashed on /dev/sda11

Ok so here’s everything I did till now.

So I initially had a dual boot windows/Linux mint system. I grew tired of windows gagging all the storage on my 1TB HDD.
, A background story of me: I’m a hobby Android kernel hacker, however due to me being a student I need windows for some stuff.

All my kernel sources are stored on Linux mints /dev/sda11 which is also my /home.

Recently I decided to build my kernels using Clang10, however it required glibc from ubuntus 19.04
Mint is on 18.04.
Which took me to go ahead and wipe out windows entirely and go full linux. I downloaded and tried to install PopOS (the latest on upto this day)

However, it so happened that PopOS tried to install the i386 platform(I’m on amd64 I suppose)
It’s also here that I formated several partitions into the ones you see in @ringo 's first post.

I restarted and I no longer could boot into the system. Then I felt I should install EnOS (I liked it’s community and helpful nature to PC noobs like me)
Till now whatever I’ve been doing was in Legacy mode as I read on Ubuntu forums that it’s recommended to turn off secure boot and do this on Legacy.