Can't boot into LiveUSB

Hello! I’m trying to install EndeavourOS on my PC, i’ve been using Linux for about a year now.

I made a LiveUSB using USBWriter on a Windows laptop with an 8GB USB, whenver i try to boot i get to the splash screen and when trying to boot into the live environment all i get is

Probing EDD (edd=off to disable)... ok

ZSTD-compressed data is corrupt

-- System halted

can you use ventoy

Welcome to EnOS’ community @NDXDirectorsCut!

Did you verify the integrity of your downloaded ISO?

USBWriter said it installed succesfully, but i can try ventoy

I used the GitHub Mirror so maybe i’ll try a different one aswell.

Try checking the checksum of the downloaded ISO regardless where you download it from or what tool you use to make a bootable USB.

how would i go about doing that?

From the website
image
You can download the sh512sum file here.

Read more at:

You should be able to find an equivalent command in windows.
If you are using PowerShell:

certutil -hashfile "EndeavourOS_Apollo_22_1.iso" SHA512

Then you can type

cat EndeavourOS_Apollo_22_1.iso.sha512sum

and compare the two outputs

2 Likes

they seem the same to me

SHA512 hash of EndeavourOS_Apollo_22_1.iso:
9e78c0294622c2677b41eff667bb9f26572818a533904063ca0657dc342c901f98749e40b55d59d7a19dce9a4d7ae6cc9c54d751845e179cc157aa43fa372d24
CertUtil: -hashfile command completed successfully.

PS C:\Users\USER\Downloads> cat EndeavourOS_Apollo_22_1.iso.sha512sum
9e78c0294622c2677b41eff667bb9f26572818a533904063ca0657dc342c901f98749e40b55d59d7a19dce9a4d7ae6cc9c54d751845e179cc157aa43fa372d24  EndeavourOS_Apollo_22_1.iso
1 Like

Then there is an issue with the program you are using to burn the iso to your USB. As suggested by @Stephane please try to use Ventoy. Ventoy works for me most of the time.

Still doesn’t work
I get this instead

If you have possibility use another USB flashdrive and perhaps another tool like rufus in dd mode.

1 Like

Or Belana etcher it verifies the write.Here

all i get is a blinking cursor now (using rufus)

tried rebooting and now i get this

From the first post it seems that there is an issue with zstd?
Even the most recent screenshot shows

error while loading shared libraries: libzstd.so.1

@NDXDirectorsCut try Balena Etcher and see how it goes

god damn It was the most stupid issue

No attempt to boot had any consistency and the ISO checksum (on Ventoy) was the same even after the errors.

Turns out the issue (i think??? still not sure it seems really stupid) was my RAM, i had it in slot 1 and 2 instead of 1 and 3 (It’s dual-channel)
I’ve booted into the Live environment fine and everything seems to work rn

Thanks everyone for all the help anyway! The answers came quick and were helpful even if they didnt solve it right away,

3 Likes

Happy that your issue is solved.
Welcome to :enos: forums!!
Mark the post that solved your issue as the solution for future users having the same issue.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.