Can't boot into Linux after BIOS upgrade

I am running Dual Boot Windows 11 and EnOS setup.
I just updated my BIOS, and now I can only select Windows 11 in the boot menu. I can’t get into Linux.
Since BIOS settings got reset after the update, I’ve set them up as they were before the update.

Did I just mess everything up or is there a fix?

Should be fixable.

Can you boot off the live ISO and run a couple commands?

sudo efibootmgr -v
sudo parted -l

I did, and got the following output:

[liveuser@eos-2022.06.23 ~]$ sudo efibootmgr -v
BootCurrent: 0001
Timeout: 1 seconds
BootOrder: 0000,0001,0002
Boot0000* Windows Boot Manager	HD(1,GPT,98e2fb88-b2f0-44e8-ab6a-f76821e6b2fb,0x800,0x32000)/File(\EFI\MICROSOFT\BOOT\BOOTMGFW.EFI)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}...1................
Boot0001* UEFI: ADATA USB Flash Drive 1100	PciRoot(0x0)/Pci(0x1,0x2)/Pci(0x0,0x0)/USB(7,0)/CDROM(1,0x369fc0,0x33298)..BO
Boot0002* UEFI: ADATA USB Flash Drive 1100, Partition 2	PciRoot(0x0)/Pci(0x1,0x2)/Pci(0x0,0x0)/USB(7,0)/HD(2,MBR,0xab3ab792,0x369fc0,0x33000)..BO
[liveuser@eos-2022.06.23 ~]$ sudo parted -l
Model: WD Elements 25A1 (scsi)
Disk /dev/sda: 4001GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name      Flags
 1      1049kB  4001GB  4001GB  ntfs         Elements  msftdata

Model: ADATA USB Flash Drive (scsi)
Disk /dev/sdb: 7973MB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size   Type     File system  Flags
 2      1833MB  1940MB  107MB  primary  fat16        esp

Model: Force MP600 (nvme)
Disk /dev/nvme0n1: 2000GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt
Disk Flags: 

Number  Start   End     Size    File system  Name                          Flags
 1      1049kB  106MB   105MB   fat32        EFI system partition          boot, esp
 2      106MB   123MB   16.8MB               Microsoft reserved partition  msftres
 3      123MB   524GB   524GB   ntfs         Basic data partition          msftdata
 5      524GB   2000GB  1475GB  ext4
 4      2000GB  2000GB  590MB   ntfs                                       hidden, diag

In the live ISO, I could access the filesystem of my EnOS.


It looks like your EFI entry was removed by the BIOS upgrade.

Reinstalling grub should fix it.

Follow the instructions for UEFI installs from here:

You root device is /dev/nvme0n1p5 and your efi partition is /dev/nvme0n1p1


Damn, that was the solution for sure.
Eventhough sudo fdisk -l showed /dev/sdb and not /dev/nvme0n1 I still went with the root device, and efi partition that you named for me, and it worked.

arch-chroot /mnt worked after that, and output of ls /home was “smokus” so that worked as well.

I then ran these two commands:

grub-mkconfig -o /boot/grub/grub.cfg
grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=EndeavourOS-grub

and after that I could select EnOS in the Boot menu, and was successfully booted into it.

Thanks a bunch!!!


Glad to help!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.