Can't Boot Into EndeavorOS after installation

I recently installed EndeavorOS and now when I try to boot into it it shows the Following Error:
sh: can't access tty: job control turned off

I did see alot of explanation about this all over the Internet and finally stumbled upon here.

There were some explanations, which I did Try.
But Nothing seems to work whatsoever.

I’ve some important work to do and I don’t think its the best to keep this topic lingering like so.

With all due respect, I’d like someone to look into this matter asap.


Welcome to :enos: forums.

  • Was it working before the error?
  • What did you do before this error started popup?
  • What solution/s did you try?

Well sorry about your work and this is a community forum people will answer if they feel like it. Ans if they think they can help solve it.

Don’t demand. This is not a paid service. It’s a community of people who would answer if they like to help out demanding things is not a good start.


I mean yea.
I’m not ordering or anything
More like an intense request.

Here’s the Respective Answers:

  • Nope I’m a new user.
  • I just booted into the live USB and did the offline install and erased the whole disk.
  • I tried removing /dev/console(didn’t go as planned so I just reinstalled it[same error btw])
  • IzumiCypherX

Wow! Looks like you will get a ton of sympathy.
The easiest way to fix this would be to boot with an archlinux installation media or the EndeavourOS media, perform a chroot and reinstall the kernel using pacman. Look here for instructions:

1 Like

Umm I did follow and do the following:
mount /dev/sdX /mnt arch-chroot /mnt pacman -S linux exit reboot
And It still does the same

Something else that would prevent the topic from lingering is to provide some information about your hardware, for example the output of inxi -Faz .


Have you tried any other Linux distros? Does this happen with every Linux distro you try?
Also, do you have a separate boot partition? That would have to mounted as well.

Did you exchange the /dev/sdX with the proper drive partition that has Endeavouros installed on it?