Can't boot installer with 4090 GPU - how to proceed?

Hi there!

I am the lucky owner of an NVIDIA 4090 GPU, and I believe that support for that class of GPU requires newer NVIDIA drivers than are in the latest installer package for EndeavourOS.

What’s the best path forward for getting EndeavourOS installed on this machine? I’d prefer to not have to swap to an older video card if possible.

Can I rebuild the installer somehow to use the latest NVIDIA drivers from the update repository? I see this post about customizing packages, but it looks like it takes effect after the installer is running already, and mine doesn’t get that far.

I don’t know the EOS update schedule very well, so if there’s an update coming in the next couple of weeks then I could just wait for that. (Or I’m happy to try out a pre-release installer if that would be helpful.)

Thanks for any guidance you can provide!

Yes. You would need to rebuild the ISO with newer packages or have one of us do it for you.

Unfortunately, it is a bit trickier than normal to build an ISO right now.

Thanks for the very prompt response!

I’m OK with a little trickiness, if there are directions to follow. My Googling is letting me down, though, and all I can find are instructions on how to create install media from the ISO image…

The instructions are here but they don’t work fully right now because of changes since the last release.

The modifications needed are:

  • Rebuilt calamares package
  • Remove packages missing from the repos from the package lists for the ISOs

I was able to create an ISO for another user booting on the 520.xx version and using nomodeset but after install it still booted to black screen. Nvidia has put out the 525.xx series drivers but it’s not on Arch yet. I had him install the nvidia-beta-dkms that is the 525.xx version from the AUR and is working for now. @dalto Are we able to build an ISO with the nvidia 525 version. I just don’t know how it all works. Somehow i managed to do it for the 520 series maybe now that the 525 series is out from nvidia it will use those if i built it. I just know they aren’t in the Arch repo yet.

It is possible. It takes some special handling though.

I’m just not sure where in the process and how the nvidia driver gets uploaded to be the latest from nvidia so that it will be on the ISO to boot on. I did it before but I’m winging it. :wink:

Edit: How do i check what nvidia version of the driver is on the live ISO. I built one right now. Almost done.

Edit: Just use inxi -Ga on the live ISO?
EDit: I guess i can’t do that because the 525.xx drivers are only for the RTX 4080 & RTX 4090 i think so it probably won’t boot on my GTX 1060 anyway. :thinking:

Thanks – I gave it a try on the Linux I have available (a “pure Arch” install on hardware and EOS on WSL2) and both ran into issues I didn’t quite know how to resolve, so I’ll wait for an update at this point I guess.

Thanks for your responses!

Supported products for the 525.53 drivers at list 1060 as being OK, FWIW.

Here’s a similar issue and he built a working ISO:

Okay … I see that now. I was wondering if they just had a special driver setup strictly for the RTX 4090 cards. I have another user was able to make it work with my ISO with the 520.xx drivers which makes two now.


Have you tried booting on any ISO yet?

I’ve only tried the 9.22 release and it doesn’t work (goes to black screen during initial boot).

9.22 release? What is that?

Here is a link to google drive for the ISO. I will leave it up for a couple of hours so you can download it. You can try it and see if it boots on the nvidia option in the menu. You may need to try nomodeset as a kernel parameter if it doesn’t. Make sure you wait a bit at boot for it to load as it takes a bit.

Sorry, I meant the Artemis Nova 22_9.iso is what I tried. Got your ISO and I’ll try it tonight, thank you!

1 Like

Worked like a charm on the NVIDIA boot option, thank you!

1 Like

Can you post

inxi -Ga

Sure thing.

inxi -Ga
  Device-1: NVIDIA AD102 [GeForce RTX 4090] vendor: Gigabyte driver: nvidia
    v: 520.56.06 alternate: nouveau,nvidia_drm non-free: 520.xx+
    status: current (as of 2022-10) arch: Lovelace code: AD1xx
    process: TSMC n4 (5nm) built: 2022-23+ pcie: gen: 4 speed: 16 GT/s
    lanes: 16 ports: active: none off: DP-2,DP-3 empty: DP-1,HDMI-A-1
    bus-ID: 08:00.0 chip-ID: 10de:2684 class-ID: 0300
  Device-2: Logitech BRIO Ultra HD Webcam type: USB
    driver: hid-generic,snd-usb-audio,usbhid,uvcvideo bus-ID: 4-1.3:4
    chip-ID: 046d:085e class-ID: 0300 serial: BD643F95
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.5
    compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
    alternate: fbdev,nouveau,nv,vesa gpu: nvidia,nvidia-nvswitch
    display-ID: :1 screens: 1
  Screen-1: 0 s-res: 5600x3840 s-dpi: 107 s-size: 1330x912mm (52.36x35.91")
    s-diag: 1613mm (63.49")
  Monitor-1: DP-2 note: disabled pos: top-right model: Gigabyte M32U
    serial: 21451B001153 built: 2021 res: 2160x3840 dpi: 141 gamma: 1.2
    size: 390x700mm (15.35x27.56") diag: 800mm (31.5") ratio: 16:9 modes:
    max: 3840x2160 min: 640x480
  Monitor-2: DP-3 mapped: DP-4 note: disabled pos: primary,bottom-l
    model: Dell AW3420DW serial: #ASONM/I5x9fd built: 2020 res: 3440x1440
    dpi: 109 gamma: 1.2 size: 798x335mm (31.42x13.19") diag: 865mm (34.1")
    modes: max: 3440x1440 min: 640x480
  API: OpenGL v: 4.6.0 NVIDIA 520.56.06 renderer: NVIDIA GeForce RTX
    4090/PCIe/SSE2 direct render: Yes

Awesome … can’t wait till the 525.xx drivers land for you.