Can't boot Eos!

Just installed Eos and stuck on this.

Wait, that should be ok.

1 Like

the file check doesn’t stop. i waited a whole day for it to end(It didn’t end, i shutdown).
And I think the file scan is running for the EFI partition. So the only way that i could boot eos was to skip the file scan everyboot. Something is wrong with my pc :frowning:

First of it would be nice to start knowing more details such as the hardware and are you installing this as a dual boot with Windows?

How are you able to skip the file scan and does it then boot to the desktop?

If you are able to boot to the desktop and have internet? Post the url
Otherwise you can boot on the live ISO.

inxi -Faz | eos-sendlog

Also post

lsblk -fm
1 Like

i did this.
After doing this i am able to boot into eos. but the fsck scan is turned off(So the problem is not solved!).

sda                                                                                          931.5G root  disk  brw-rw----
│    vfat   FAT32            0236-F029                                                         100M root  disk  brw-rw----
│                                                                                               16M root  disk  brw-rw----
│    vfat   FAT32            DA41-97B2                                                         100M root  disk  brw-rw----
│    ntfs                    9EE60A45E60A1DE1                                                  184G root  disk  brw-rw----
│    ntfs                    2A4866304865FAC9                                                  509M root  disk  brw-rw----
│    ntfs                    2CB493CEB4939942                                                  509M root  disk  brw-rw----
│    ntfs                    364604AF46047243                                                  608M root  disk  brw-rw----
│    ext4   1.0              a14673c2-a1c0-469c-88a7-2790bbcba01e                               93G root  disk  brw-rw----
│    vfat   FAT32            DEF7-02D2                                                         513M root  disk  brw-rw----
│    ext4   1.0              3a768d05-4e39-4d86-aa90-1c36d89cceb9                            109.5G root  disk  brw-rw----
│    vfat   FAT32            D085-783C                                                         100M root  disk  brw-rw----
│    ext4   1.0              79b25f26-5127-4f34-b99a-f2895c15967c                             97.6G root  disk  brw-rw----
│    vfat   FAT32            5CFE-E626                                                         100M root  disk  brw-rw----
│    vfat   FAT32            CC57-394C                                                         100M root  disk  brw-rw----
│    ntfs                    56CA2841CA281FAB                                                  545M root  disk  brw-rw----
│    swap   1                576184e0-57d7-464f-8637-c62619ab14e8                [SWAP]        3.9G root  disk  brw-rw----
│    ntfs         New Volume CA5AFE125AFDFAD1                                                118.6G root  disk  brw-rw----
│    ntfs         Arjun      8858175F58174B78                                                199.9G root  disk  brw-rw----
│    vfat   FAT32            2664-6890                               382M    56% /boot/efi     873M root  disk  brw-rw----
│                                                                                               10M root  disk  brw-rw----
│    ntfs         RECOVERY   1311327301F40FC3                                                 26.4G root  disk  brw-rw----
     ext4   1.0              d2c91d5b-19a4-4cf5-92e6-2d37be271630   81.7G     7% /            94.7G root  disk  brw-rw----
sr0                                                                                           1024M root  optic brw-rw----

edited by moderator to add code tags

I guess my efi partition has to do with problem

I’m not really understanding the disk layout. You have 4 100M partitions that look like efi partitions? Plus the one marked /boot/efi which i assume is the EndeavourOS install.

Edit: Windows should have one of it’s own. Not sure what the others are for.

Edit2: Can you post an image of

sudo fdisk -l

The first 100mb partition is obviously for windows and the 873 mb partition(/boot/efi) is a partition that i manually created for EFI partitions for linux installs(I have zorin os and and old install of eos alongside). Not sure about the other EFI partitions.

Looks like you have a Bios boot partition also? I’m not sure why fsck won’t run. Do you know exactly what partitions are for the linux installs? By this i mean which one is the current eos install, which one is zorin and which one is the old eos install? Also did you install with grub or systemd-boot?

Edit: Maybe @pebcak could help?

1 Like

The old eos install is systemd.
The new one is grub.
the current eos install : sda22
the old eos install : sda8
zorin : sda12 ig
Other partitions except the EFI system (fat32) include windows, my files etc…

oops i forgot, zorin is a bios install.

Don’t know why fsck won’t run so I’m not sure what to advise. Someone else maybe can weigh in on this because i don’t want to waste your time if it isn’t going to work. :man_shrugging:

Edit: It may have something to do with the fstab entries?

Maybe also post this

cat /etc/fstab

Yes for each fstab of each linux install…

I wonder why you have so many EFI partitions.

For example, I run three distros under Macintosh… But I have one EFI partition. For MacOs boatloder and the other boatloders (grub, systemd-boot, and refind) it works…

I only had to grow this partition for systemd-boot because the initrds and kernels have to be on this partition.

I’m not sure that UEFI spécifications allows many EFI partition on the same disk.

  • obviously uefi specs allow it but not necessarly all distros
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=2664-6890                            /boot/efi      vfat    defaults,noatime 0 2
UUID=d2c91d5b-19a4-4cf5-92e6-2d37be271630 /              ext4    defaults,noatime 0 1

I don’t have any prob running eos now. but , isn’t it bad to skip the fsck scan(temporary fix that i found)?
like maybe won’t i have any problem in future?

Can you explain how you succeed to boot eos now ?

I must have miss something inbetween :slight_smile:

Ok I missview your answer…

I wonder if this efi check of your Efi partition is really necessary…

I wonder if the check of your efi score is really necessary.
At worst, if it is corrupted, you destroy it / remake it.

You can also keep a backup of it, once and for all, just in case. It doesn’t move every day either.

for the efi my fstab looks like that

UUID=C80D-E885 /efi vfat umask=0077 0 1

1 Like

So, scanning the efi partition is not necessary, right?
or i should destroy the efi partition and create a new fresh one.
ok thank you all for the answers!.
for the time being, i’m not going to change anything.(I guess it is ok).