Can't boot (boot loop)

Hello I downloaded is 2 times and first used Vento and then flashed using Rufus. It shows the selection of endeavor but if I click one it puts me back

Make sure that secure boot is disabled in the BIOS.

It already is
Plus recognize me?

I am able to get into endeavors boot loader just not past it

So you are getting to the grub screen and when you select an option it reboots?


Are you selecting the default option or the non-free option?

Can you share what your hardware is? gpu/cpu and if it is a laptop or a desktop?

I tried both. I am having a amd a8 7410 and a r5 m430. It’s a laptop and currently rocking a Garuda install.

Had similar problem with Rufus, iso was only working with Etcher.

1 Like

I think the problem is the related to the graphics as this is an apu with radeon. Maybe check what Garuda has in the default grub command line?

I fail to understand as to why that would matter?

Nope. Didn’t work


System: Kernel: 5.14.16-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=29b8b254-7d1f-4b8f-9cc6-50b7fbffe934 rw rootflags=subvol=@ quiet splash
rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1
loglevel=3 amd_iommu=on iommu=pt
Desktop: LXQt 1.0.0 tk: Qt 5.15.2 info: cairo-dock, lxqt-panel wm: kwin_x11 vt: 1
dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine: Type: Laptop System: LENOVO product: 80TJ v: Lenovo ideapad 110-15ACL
serial: Chassis: type: 10 v: Lenovo ideapad 110-15ACL serial:
Mobo: LENOVO model: Nano 5A8 v: SDK0J40679 WIN serial: UEFI: Lenovo
v: 1QCN32WW date: 08/18/2016
Battery: ID-1: BATT charge: 1.6 Wh (100.0%) condition: 1.6/23.8 Wh (6.7%) volts: 12.2
min: 10.8 model: LENOVO LCFC type: Unknown serial: status: Full
CPU: Info: Quad Core model: AMD A8-7410 APU with AMD Radeon R5 Graphics bits: 64 type: MCP
arch: Puma family: 16 (22) model-id: 30 (48) stepping: 1 microcode: 7030105 cache:
L2: 2 MiB
flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 17568
Speed: 2249 MHz min/max: 1000/2200 MHz boost: enabled Core speeds (MHz): 1: 2249
2: 2302 3: 2185 4: 2260
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Full AMD retpoline, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics: Device-1: AMD Mullins [Radeon R4/R5 Graphics] vendor: Lenovo driver: radeon v: kernel
alternate: amdgpu bus-ID: 00:01.0 chip-ID: 1002:9851 class-ID: 0300
Device-2: AMD Sun XT [Radeon HD 8670A/8670M/8690M / R5 M330 / M430 / Radeon 520
vendor: Lenovo driver: radeon v: kernel alternate: amdgpu bus-ID: 01:00.0
chip-ID: 1002:6660 class-ID: 0380
Device-3: IMC Networks EasyCamera type: USB driver: uvcvideo bus-ID: 2-1.2:4
chip-ID: 13d3:a745 class-ID: 0e02 serial:
Display: x11 server: X.Org compositor: kwin_x11 driver: loaded: ati,radeon
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 101 s-size: 344x193mm (13.5x7.6")
s-diag: 394mm (15.5")
Monitor-1: eDP res: 1366x768 hz: 60 dpi: 101 size: 344x193mm (13.5x7.6")
diag: 394mm (15.5")
OpenGL: renderer: AMD KABINI (LLVM 14.0.0 DRM 2.50 5.14.16-zen1-1-zen)
v: 4.5 Mesa 22.0.0-devel (git-4a38ed822a) direct render: Yes
Audio: Device-1: AMD Kabini HDMI/DP Audio vendor: Lenovo driver: snd_hda_intel v: kernel
bus-ID: 00:01.1 chip-ID: 1002:9840 class-ID: 0403
Device-2: AMD FCH Azalia vendor: Lenovo driver: snd_hda_intel v: kernel
bus-ID: 00:14.2 chip-ID: 1022:780d class-ID: 0403
Sound Server-1: ALSA v: k5.14.16-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.39 running: yes
Network: Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter vendor: Lenovo
driver: ath10k_pci v: kernel bus-ID: 02:00.0 chip-ID: 168c:0042 class-ID: 0280
IF: wlan0 state: up mac:
Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Lenovo driver: r8169
v: kernel port: 1000 bus-ID: 03:00.0 chip-ID: 10ec:8136 class-ID: 0200
IF: enp3s0 state: down mac:
IF-ID-1: wlan1 state: down mac:
Bluetooth: Device-1: Qualcomm Atheros type: USB driver: btusb v: 0.8 bus-ID: 2-1.1:3
chip-ID: 0cf3:e360 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 2 state: up address:
Drives: Local Storage: total: 223.58 GiB used: 59.46 GiB (26.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital model: WDS240G2G0A-00JH30
size: 223.58 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD
serial: rev: 0000 scheme: GPT
Partition: ID-1: / raw-size: 79.65 GiB size: 79.65 GiB (100.00%) used: 59.42 GiB (74.6%)
fs: btrfs dev: /dev/sda3 maj-min: 8:3
ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%) used: 38.8 MiB (7.6%)
fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 79.65 GiB size: 79.65 GiB (100.00%) used: 59.42 GiB (74.6%)
fs: btrfs dev: /dev/sda3 maj-min: 8:3
ID-4: /var/log raw-size: 79.65 GiB size: 79.65 GiB (100.00%) used: 59.42 GiB (74.6%)
fs: btrfs dev: /dev/sda3 maj-min: 8:3
ID-5: /var/tmp raw-size: 79.65 GiB size: 79.65 GiB (100.00%) used: 59.42 GiB (74.6%)
fs: btrfs dev: /dev/sda3 maj-min: 8:3
Swap: Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 6.69 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors: System Temperatures: cpu: 80.6 C mobo: N/A
Fan Speeds (RPM): N/A
GPU: device: radeon temp: 57.0 C device: radeon temp: 75.0 C
Info: Processes: 224 Uptime: 3m wakeups: 1 Memory: 6.69 GiB used: 2.68 GiB (40.0%)
Init: systemd v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: N/A Packages:
pacman: 1372 lib: 355 Shell: fish v: 3.3.1 default: Bash v: 5.1.8
running-in: alacritty inxi: 3.3.08

Maybe try the same kernel parameters in the grub boot menu. Press e for edit on the default grub menu entry and add these to the end of the default grub command line. You can use the arrow key to get to the end of the line.

amd_iommu=on iommu=pt

Nope I removed them and still nothing :frowning:

Anyone have any ideas?

I guess i’m not understanding you. You have a system running on Garuda. I"m not sure if you are trying to install EOS or something else? From what i read it sounds like you try to boot on the EOS ISO but it won’t load or boot past a cerrtain point. At least that’s what i thought. If that was the case i wanted you to add the entries to default grub command line on EOS when you try to boot on the EOS ISO. If this isn’t what the issue is then a better explanation is needed because i don’t understand what the problem is.

Yes that’s my issue

opposite should be the test… adding the parameter to try if EndeavourOS ISO will boot with them :wink:


Try these kernel parameters

amd_iommu=on iommu=pt radeon.si_support=0 amdgpu.si_support=1