Can't Boot After Upgrading EndeavourOS

Hi all,

I dual boot windows 10 and Endeavouros. I did an upgrade to EOS and then the system told me to reboot. I did that and now it only boots into BIOS. I go to Advanced to change the boot order, and the only option now is Endeavouros, but it won’t boot. It doesn’t recognize the Windows partition - its not even an option to select in the boot order menu.

It’s like the upgrade broke the grub boot menu I use to select between EOS and Windows 10.

I’m currently writing here using a bootable Ubuntu USB. I can view that all the partitions are still there, but I can’t get out of the loop of continually booting into BIOS.

Any help would be GREATLY appreciated.

How long has it been since you updated?

Hi Dalto!

I probably originally installed EOS 12 months ago and haven’t really used it. Thought it would be fun to get back into again. So, I tried to do the following command:


But kept having issues as it seemed my keyrings weren’t updated.

I cleared my cache. I updated the keyrings and then tried pacman -Ssy (I believe that was the command)

Nothing would upgrade.

I then refreshed the keyrings. No change. I then refreshed the endeavouros repository keyrings (I believe I’m saying that correctly). Then, I was able to upgrade. The system told me to reboot and now here I am

You likely hit the infamous grub issue from last year.

The easiest way to fix it is:

Alternatively, you could reinstall.


Ok awesome! I’ll try that. I’ll have to create a bootable USB drive, so it may take some time before I can update you. Thank you SO much for the QUICK!! assistance. I’ll keep you posted.

1 Like

Could I technically do this from the ubuntu bootable drive since I can do chroot there? Or is it best to do it from an endeavourOS ISO?

You technically can but since you don’t have arch-chroot you would have to manually setup the chroot. arch-chroot does all that for you. We don’t have any instructions for that but it is possible.

It isn’t that hard it is just some extra steps.

Ubuntu has this package:
which delivers arch-chroot.

1 Like

Because of the issues I’ve had updating…anything…I’m going to reinstall EndeavourOS.

Now, previously, I used the Grub bootloader. Would I be ok to change this to be systemd-boot without fixing the above issue first? or would it be better to stick with grub?

You can do either. Reinstalling will fix the grub issue.

1 Like

Waiting for your answer, I thought I would ask about this as well.

I don’t have anything on the existing instance of endeavouros, so I’m happy to reinstall and overwrite it. So, I think I should be good to choose ‘replace a partition’ and then select the 389Gb ext4 partition EndeavourOS originally on, right?

I just want to make sure that I’ll be able to still dual boot into my windows 10 partition (which should be the blue partition in the image, above)


Yes, should be able to do that without issue.

1 Like

Thank you so much! Fingers crossed…here we go


Thank you again so much - my issues are fixed!!

Other than the grub thing (that’s on grub), this EndeavourOS install has been the easiest out of any platform I’ve tried. And so far the support is unparalleled. Thank you again!!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.