Can't adjust brightness on Acer Nitro laptop

I’ve been looking through this forum extensively at similar topics/issues and have struggled to find a lasting solution on this issue. The brightness slider doesn’t change anything, nor do my keyboard brightness keys. I have tried editing my grub config file but no luck so far. The only temporary solution was using “brightness-controller” but it stopped working when I did a system update. I’m assuming this is because of the nvidia hardware.

Any help would be appreciated. I am not super comfortable with linux yet so clear explanations, in-depth answers will go a long way. Thanks in advance.

Hi dox_1,

can you post more information about your setup?
eg Which desktop environment are you using?
What edits did you try to make in your grub config?

Does brightness-controller report any errors?

Meanwhile you could try xbacklight (the package name is xorg-xbacklight) or brightnessctl.

Sure thing. Here’s my setup:

Operating System: EndeavourOS
KDE Plasma Version: 6.0.5
KDE Frameworks Version: 6.3.0
Qt Version: 6.7.1
Kernel Version: 6.9.4-arch1-1 (64-bit)
Graphics Platform: Wayland
Processors: 12 × 12th Gen Intel® Core™ i5-12450H
Memory: 15.3 GiB of RAM
Graphics Processor: Mesa Intel® Graphics
Manufacturer: Acer
Product Name: Nitro AN515-58
System Version: V2.05

the edit I did to my grub config was adding “acpi_backlight=nvidia_wmi_ec” to the “GRUB_CMDLINE_LINUX=” line

brightness-controlller doesnt provide any errors but does say my display is invalid and the GUI states Laptop displays aren’t supported, although it was working fine before I performed the system update.

I tried xbacklight but it reports “No outputs have backlight property”

brightnessctl attempts to work but no matter what number i set, the actual brightness of my screen doesnt change. No errors get reported.

So much stuff to try: - make sure to read readme and script. And if inotifywait is installed on your system

1 Like

Finally got it to work, I followed this solution from the previously mentioned askubuntu thread:

sudo gedit /etc/default/grub

Replace GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

With GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash pcie_aspm=force acpi_backlight=native”

press ctrl+s , close the text editor

sudo update-grub (did "sudo grub-mkconfig -o /boot/grub/grub.cfg" instead)

Then reboot your system.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.