Can't add network printer

For some reason my network printer (EPSON L6190) is not recognized. I added the printing extras when installing EOS, as well as ‘epson-inkjet-printer-escpr2’. Also amended the /etc/nsswitch.conf file. But the printer is not discovered in cups or printer settings page.

Any tips welcome.

This is very helpful https://discovery.endeavouros.com/printers/printers/
and https://www.openprinting.org/printers

Have you installed avahi network browser as part of your nsswitch configuration?

Check firewalld is letting mdns through.

local hostname resolution is not enabled i would bet… firewall should be fine.
Info on how to enable is at the bottom of the printer wiki.
Or here:
https://wiki.archlinux.org/title/Avahi#Hostname_resolution

Thanks, I followed the guide on the EOS website, and avahi is installed. Driver for Epson L6190 is in the ‘epson-inkjet-printer-escpr2’ package (it’s not listed on the OpenPrinting website).

It is definitely not a question of the printer being supported under Linux - it ran under Manjaro and PopOS. I’m just missing a step or two in setting it up from scratch on EOS.

Firewalld default zone is public, that zone does not allow mdns so avahi will not discover printer. Try changing to home zone as mdns is allowed.

Hello @Algrin and welcome to the :enos: forum. Have fun :partying_face:

Thanks @HMS-Endeavour.

Even though it’s not listed, I had the same situtation with Manjaro, but rather than go backwards, I persisted and got it working on :enos: Guessing you have already seen this https://www.epson.com.sg/Ink-Tank-Printers/L-Series/Epson-L6190/s/SPT_C11CG19502?review-filter=Linux

system-config-printer will do that on foirst usage automatically…

1 Like