Can't Access TTY from Login Screen

Using XFCE online version with i3 as a secondary DE.
Nothing is wrong with my system but I have had to reinstall a few times due to critical newbie errors as I have been getting used to EnOS and Linux in General.

I set up timeshift to have a backup on my HDD 1TB drive and know that if my system blows up again I would need to access timeshift from TTY and wanted to learn how to do that.

Unfortunately when I CTRL+ALT+F2 at the login screen it pulls me to the tty but I cant type into it and it looks frozen. It currently just has the startup processes listed like mounted drives auto start programs etc.

I am using Grub and fresh installed yesterday so very little has been introduced to the system.

Nvidia geforce 2070 Prime if that matters.
DP port into my monitor if that also somehow matters.

welcome onto purpelizations :enos:
Could be TTY2 is not available (not sure why?) usually it is TTY1 that is used to start… i mean where the startup log is visible…

You have tried TTY3 4 5 6 ?
Ctrl Alt F3

1 Like

TTY3-6 gives me the same thing and I can’t even TTY1 back into login from this screen its just frozen.

also thanks for the welcome!

Seems a general GPU driver issue… you should be able to login when booting in single user mode:
https://discovery.endeavouros.com/system-rescue/how-to-boot-without-a-graphical-environment/2021/03/

I believe you need to edit the logind.conf file, uncomment these lines:

Then enable & start the service

systemctl enable getty@tty6.service
systemctl start getty@tty6.service

where 6 is the number of TTY’s (default in the logind.conf)

also check you have agetty installed

which agetty

I am not using systemd I am using grub will that matter? Currently at work so I will look into your solution and @joekamprad solution when I get back home to see if it works.

Do you mean you’re not using systemd-boot?
systemd is a service manager, GRUB is a boot loader.

When I installed initially I chose the grub option not the default. If that’s what you mean? The default being what I thought was systemd-boot.

I use GRUB, and have systemd for running services, as far as I know endeavourOS doesn’t give the option for changing the service manager. (don’t quote me on that)
I assume you will have the same setup, which you can confirm when your home simply by seeing if the logind.conf file exists.

The file exists and I uncommented the lines in the .conf ran the commands but still nothing.

[jdr@EnOSDean ~]$ which agetty
/usr/bin/agetty
[jdr@EnOSDean ~]$

That was the result that popped out of that enquiry

This also didn’t work for me. Is it possible that the zen kernal is somehow the culprit. And if so How would I switch to the normal kernal and get rid of the Zen kernal.

You may need to reboot after editing the .conf file and enabling & starting the service. (sorry, forgot to mention)

re: output of which agetty
good. That tells you it’s installed & where it is located.

ctrl + alt + any key from F2 to F6 to enter TTY
ctrl + alt + F1 to go back to the graphical interface

I am sure this is irritating. It is quite frustrating to me so I apologize.

I followed the instructions for editing the config enabled and started the service.

Rebooted, and then tried TTY access before logging in and afterwards and it still freezes on the same screen that I posted above.

You do not have kernel selection screen in Grub? did you remove standard kernel after installing Zen?

Show us your inxi -FAZ --no-host | eos-sendlog

inxi -FAZ --no-host

Summary

System:
Kernel: 6.3.2-zen1-1-zen arch: x86_64 bits: 64 Desktop: Xfce v: 4.18.1
Distro: EndeavourOS
Machine:
Type: Desktop Mobo: ASUSTeK model: PRIME X370-PRO v: Rev X.0x
serial: UEFI: American Megatrends v: 6042
date: 04/28/2022
CPU:
Info: 12-core model: AMD Ryzen 9 3900X bits: 64 type: MT MCP cache:
L2: 6 MiB
Speed (MHz): avg: 2574 min/max: 2200/4918 cores: 1: 2200 2: 2200 3: 2200
4: 2200 5: 2200 6: 2200 7: 2200 8: 2200 9: 4000 10: 2200 11: 2200 12: 2200
13: 4000 14: 4000 15: 4000 16: 2200 17: 2200 18: 3999 19: 2200 20: 2200
21: 2200 22: 2200 23: 2200 24: 2200
Graphics:
Device-1: NVIDIA TU106 [GeForce RTX 2060 Rev. A] driver: nvidia v: 530.41.03
Device-2: AMD Caicos [Radeon HD 6450/7450/8450 / R5 230 OEM]
driver: radeon v: kernel
Device-3: Logitech C922 Pro Stream Webcam driver: snd-usb-audio,uvcvideo
type: USB
Display: x11 server: X.Org v: 21.1.8 driver: X: loaded: modesetting,nvidia
unloaded: radeon dri: r600 gpu: nvidia,nvidia-nvswitch
resolution: 2560x1440~144Hz
API: OpenGL v: 4.6.0 NVIDIA 530.41.03 renderer: NVIDIA GeForce RTX
2060/PCIe/SSE2
Audio:
Device-1: NVIDIA TU106 High Definition Audio driver: snd_hda_intel
Device-2: AMD Caicos HDMI Audio [Radeon HD 6450 / 7450/8450/8490 OEM R5
230/235/235X OEM] driver: snd_hda_intel
Device-3: AMD Starship/Matisse HD Audio driver: snd_hda_intel
Device-4: Logitech C922 Pro Stream Webcam driver: snd-usb-audio,uvcvideo
type: USB
Device-5: Logitech Yeti X driver: hid-generic,snd-usb-audio,usbhid
type: USB
Device-6: Kingston HyperX Cloud Alpha S
driver: hid-generic,snd-usb-audio,usbhid type: USB
API: ALSA v: k6.3.2-zen1-1-zen status: kernel-api
Server-1: PipeWire v: 0.3.70 status: active
Network:
Device-1: Intel I211 Gigabit Network driver: igb
IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: 60:45:cb:a1:66:d8
Bluetooth:
Device-1: Realtek Bluetooth Radio driver: btusb type: USB
Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: disabled
rfk-block: hardware: no software: no address: see --recommends
Drives:
Local Storage: total: 2.27 TiB used: 154.51 GiB (6.6%)
ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 500GB size: 465.76 GiB
ID-2: /dev/sdb vendor: Western Digital model: WD10EZEX-08WN4A0
size: 931.51 GiB
ID-3: /dev/sdc vendor: Samsung model: SSD 860 QVO 1TB size: 931.51 GiB
Partition:
ID-1: / size: 439.6 GiB used: 18.93 GiB (4.3%) fs: ext4 dev: /dev/sda2
ID-2: /boot/efi size: 998 MiB used: 288 KiB (0.0%) fs: vfat dev: /dev/sda1
Swap:
ID-1: swap-1 type: partition size: 17.08 GiB used: 0 KiB (0.0%)
dev: /dev/sda3
Sensors:
System Temperatures: cpu: 45.4 C mobo: N/A
Fan Speeds (RPM): fan-2: 1275 fan-3: 1283
GPU: device: nvidia screen: :0.0 temp: 44 C fan: 0% device: radeon
temp: 43.0 C
Info:
Processes: 408 Uptime: 3h 22m Memory: available: 15.53 GiB
used: 4.61 GiB (29.7%) Shell: Zsh inxi: 3.3.27

At this point I’m unsure what is causing the freeze,
There are three things that seem different to my system

  1. your using PRIME, but I doubt this is the issue.
  2. In inxi you have driver: X: loaded: modesetting ,nvidia mine only displays nvidia
    (I’m wondering if your integrated AMD GPU is enabling KMS even though it says ‘unloaded’
  3. Your using zen kernel

I switched kernals and also had the issue. So it’s likely nvidia I guess. Classic nvidia…I will rebuild my next PC with no nvidia or intel components. As They have decided to hate me on more than this occasion. I guess ill just try not to break my system and chroot in if needed. I am not sure how I would have integrated GPU doing anything. I am on a desktop and thought I disabled that long ago.

Well my friend, “I disabled integrated GPU” raised my both eyebrows. I would not recommend it, and this indicates you changed some stuff already.

Anyway, you can still experiment - connect monitor to different video port, if you have more than one.
Also you could boot from Live CD and practice from it - you have different drivers settings when booting live CD, one of them could work, and give you hint what does not work.

Sorry to be clear I had it disabled on windows. I dont think it stayed disabled. I had to do that about a year ago because I have an old amd graphics card that I used to hook up an old VGA CRT monitor. That monitor im not using anymore and EnOS seems to have detected that my Nvidia card is the main card. But maybe display port is causing issues. I may try HDMI later today and see if somehow that works.