Can't access EndeavorOS partition at all

Linux newbie here. This pertains to a dual boot system

I recently replaced all the components of my PC with the sole exception of my SSD. All data is intact as far as i’m aware. However, the bootloader is no longer present. So it just boots straight to windows!

I tried looking into my bios in the hopes that I could force it to boot up my EDos partition, but it doesn’t seem to recognize the partition at all. I’m essentially forced to use windows until this issue is resolved.

Advice would be greatly appreciated.

happens after a bigger windows update?

you should first take a look from booting LiveISO and see what happens to the EndeavourOS Partitions:

2 Likes

I just tried mounting the ESP EUFI partition but it tells me that it doesn’t exist.

iirc I wasn’t using grub to dual boot prior to replacing my motherboard. it was the “built in” bootloader that comes along with the installation of endeavorOS. correct me if i’m wrong on this, but this boot screen and grub aren’t the same thing right?
281926186

That is grub.

You have to replace the device name with the correct device name for your install.

If you share the results of the command:

lsblk -o name,size,type,fstype

We can probably give you the correct device name.

EDIT: Actually, looking more at your screenshot, it may be a legacy/BIOS boot install which is why you can’t mount your ESP.

3 Likes

All right. I managed to circumvent this problem at least partially by creating a bogus partition with sole purpose of reinstalling GNU grub. I have access to my desired partition again! The only thing that’s left now is to change the boot order to prioritize my main linux partition.

can you give lsblk -o name,size,type,fstype output so we can see how the partitions are look like?

1 Like

could be also a bios reset? like windows is installed in UEFI Mode but EOS was using legacy on install, and now BIOS is set to boot only UEFI? i would check BIOS for such settings and also in Windows you can check if it runs in legacy or uefi mode:
https://www.easyuefi.com/resource/check-windows-is-booted-in-uefi-mode.html

It turns out that I simply didn’t input the proper efi partition in the live ISO. Which is why I couldn’t reinstall grub at first, but now the problem is solved.

Thanks for your help regardless.