Cannot update with pacman: maybe broken dependencies

I’m trying to update my Raspberry PI installation, but I’m getting this error:

# pacman -Syu
:: Synchronizing package databases...
 endeavouros is up to date
 core is up to date
 extra       2.5 MiB  5.13 MiB/s 00:00 [--------------------] 100%
 community   6.5 MiB  10.5 MiB/s 00:01 [--------------------] 100%
 alarm is up to date
 aur is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing vid.stab (1.1.1-1) breaks dependency '' required by ffmpeg-rpi

Is this just a problem in my computer or a general bug?
Thank you in advance,

1 Like

For the record, can you show the output of

pacman -Qi ffmpeg-rpi


Is that package is still available for ARM?

My output for “pacman -Qi ffmpeg-rpi” is here:
and about the availability of the package, my output for “pacman -Ss ffmpeg-rpi” is

alarm/ffmpeg-rpi 4.4.4-1 [installed]
    FFmpeg from the release/4.4 branch with hw accel for RPi 3/4/400
alarm/ffmpeg-rpi-bin 4.4.4-1
    binaries and man pages
alarm/ffmpeg-rpi-debug 4.4.4-1
    Detached debugging symbols for ffmpeg-rpi

The version of ffmpeg-rpi (4.4.4-1) needs
While vid.stab is trying to install

vid.stab 1.1.1-1

Architecture: aarch64
Repository: extra
Description: Video stabilization library
Upstream URL:
License(s): GPL
Installed Size: 147KiB
Build Date: Mon Apr 24 23:39:50 2023 UTC

Not sure but perhaps ffmpeg need to be rebuild against this new library.

ffmpeg-rpi 4.4.4-1

Architecture: aarch64
Repository: alarm
Split Packages: ffmpeg-rpi-bin, ffmpeg-rpi-debug
Description: FFmpeg from the release/4.4 branch with hw accel for RPi 3/4/400
Upstream URL:
License(s): GPL3
Conflicts: ffmpeg4.4, ffmpeg-shinobi
Installed Size: 21MiB
Build Date: Thu Apr 13 18:20:37 2023 UTC

Ok, anyway the current situation does not come from manual source code compilation. Everything that is installed comes from the official packages, and I would like to see if it is possible to fix it using pacman, in order to keep the system clean and consistent.

the maintainers of that repository need to rebuild ffmpeg-rpi to resolve that issue. There is not much that you as a user can do about it, except manually rebuilding it.

Yes that was my thought too:

So, OP needs just to wait for it or perhaps ignore the update to vid.stab for now to be able to update the rest of the packages.

--ignore package

Directs pacman to ignore upgrades of package even if there is one available. Multiple packages can be specified by separating them with a comma.


Ok, thank you for the replies.

1 Like

According to this

ffmpeg was updated on Tue Apr 25 00:21:40 2023 UTC

and ffmpeg-rpi was updated Thu Apr 13 18:20:37 2023 UTC

Maybe these updates broke something.


Days later, the problem has not been solved.
I cannot find any reference to recent problems with vid.stab or ffmpeg-rpi on the official form:

At this point, all I have to do is to register on the Arch Linux ARM forum, report it and hope I am not treated terribly (in the official Arch Linux forum new users are bullied very often with RTFM and other such things!!! :sweat_smile:)

If you are up for testing, could you consider replacing ffmpeg-rpi with the regular ffmpeg to see if you still have the problem with updating?

sudo pacman -Syu ffmpeg

This should ask you to replace ffmpeg-rpi and update your system.


It worked! I had to uninstall first ffmpeg-rpi and vlc-rpi.
Then I installed ffmpeg and vlc.
Thank you.

1 Like

You should click on “Solution” under the post that gave you the solution, instead of renaming the thread… - the thread will be marked as solved then automatically. :wink:


ok, thank you, done


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.