Cannot update system - need missing key?

Greetings. I’m trying to breathe life into a 2011 MacMini that already has an older version of EOS on it running kernel 5.10-.11-arch-1 … but I cannot successfully run sudo pacman -Syu for some reason(s).

Most specifically, after updating the mirrors, during the process of trying to update the system, I’m asked if I am willing to accept a series of PGP keys. The first few are accepted with no issue but when I get to one that is attributed to then, regardless of whether I say “Y” or “n”, I get the same response:

error: key "A3434...blah blah" could not be looked up remotely
error: required key missing from keyring
error: failed to commit transaction (unexpected error)
Error occurred. No packages were upgraded.

Apparently my current EOS installation requires this particular key to proceed, but it’s not available.

Any workarounds come to mind? TIA.

Have you already done?

# pacman-key --init
# pacman-key --populate
# pacman-key --refresh-keys
# pacman -Sy --needed archlinux-keyring endeavousos-keyring && pacman -Su


1 Like

Awesome tip … thank you.

However, when I get to that 3rd line (--refresh-keys) the terminal hangs for quite a while saying that it’s refreshing 144 keys … and eventually responds that the “keyserver refresh failed” and “Server indicated a failure” - suggesting that at least it’s reaching the server. :man_shrugging:

Looking around on stack exchange and elsewhere for a workaround.

Thanks for aiming me in the right direction. Will update here with any breakthroughs.

UPDATE: To clarify, after the error message (including the one about not finding a local key, which I understand can be ignored) when I proceed to the 4th step cited above, I wind up with the same error trying to accept the key from again.

Hmm. Do you have eos-update installed? If so, try it to see if it makes a difference. You would just run it in a terminal like below.


If the above gives the same error or something different, but is still unable to update, check this thread: [FAQ] Issues with “signature is marginal trust”, "signature is unknown trust", or “invalid or corrupted package”

And, here is a good search query to use within this forum to find other possible fixes:

Lastly, another option is to reinstall the keys from scratch as if you were a base Arch user who wants to use the EndeavourOS repo. The link in my first response covers how to add other repos, and the link below is for EndeavourOS.

OR Adding Endeavour os repo on Arch Linux - #2 by keybreak

1 Like

Some followups …

eos-update is not a package that is not currently available for download.

However, eos-update-notifier is - and I do have that installed.

When running it explicitly just now though I get a “Checking for updates…” response which hangs with no further progress.

I think reinstalling the system from scratch - i.e., from vanilla Arch upward - may be my best alternative. Getting even this old version of EOS loaded was such a chore on this 2011 MacMini I hate to do that but it’s likely my only path forward at this point since everything else is a dead-end. :person_shrugging:

I forgot that eos-update got merged into eos-bash-shared

But alas, if you don’t already have it installed, it won’t help unless you go through the process of removing then re-adding the repo and keys.

If you already have the newest ISO, reinstalling would be faster, but if you don’t then it’s not.

If you decide to download the ISO, I’d recommend the torrent route for a more stable and possibly faster download.