Cannot stream chromecast in EndeavourOS

My preferred daily use platform OS is EndeavourOS (on an Asus Vivobook).

There are no problems with other platforms and OS’s in our home, MacOS, iPadOS, iOS, Android OS.

I had to reformat my Linux set up due to other issues. Now I have no “WiFi” icon when I try to stream Youtube videos and when I am in the Brave browser, or Vivaldi browser, when I go to File, and on the down menu select Cast, I get a dialog box that states, in a dialog box “no devices found”. I am flummoxed and frustrated.

My new and current Linux set up is:

Operating System: EndeavourOS
KDE Plasma Version: 5.24.5
KDE Frameworks Version: 5.95.0
Qt Version: 5.15.4
Kernel Version: 5.18.3-zen1-1-zen (64-bit)
Graphics Platform: X11
Processors: 2 × AMD A9-9425 RADEON R5, 5 COMPUTE CORES 2C+3G
Memory: 7.2 GiB of RAM
Graphics Processor: AMD STONEY

Any help or insight would be welcome. Thank you.

@WeeSammy Hello and welcome to the forum!

:purple_heart:

Did you install any chromecast-related packages on your machine yet?

If not, please look here.

According to the instructions given here, under “Latest Comments”,
the latest package of choice to install would probably be mkchromecast-git, via the command-line:

yay -S mkchromecast-git …after updating your system first!

Also, there is an older thread on reddit, just in case it might provide some further clues.

I actually tried to use mkchromecast but it didn’t work properly for me neither.
I also tried the built-in option in VLC but even if I could connect to chromecast it would load the first 10 seconds and after the streaming would stop.

Welcome to the forum @WeeSammy :enos_flag: :enos: :partying_face: