Cannot start VirtualBox machines

I tried to start a VirtualBox machine that was working perfectly fine, but I can’t seem to start it anymore: there’s a dialog (which cannot be closed) saying “Starting virtual machine…” but nothing else happens.

I have installed these packages (and added my user to the VirtualBox group):

yay -S linux-headers virtualbox virtualbox-guest-iso virtualbox-ext-oracle virtualbox-host-modules-arch

The journal log shows this:

kernel: SUPR0GipMap: fGetGipCpu=0x1b
kernel: traps: Missing ENDBR: 0xffffb9e1c570a320
kernel: ------------[ cut here ]------------
kernel: kernel BUG at arch/x86/kernel/traps.c:255!
kernel: invalid opcode: 0000 [#1] PREEMPT SMP NOPTI
kernel: CPU: 3 PID: 6044 Comm: EMT-0 Tainted: G           OE      6.1.1-arch1-1 #1 9bd09188b430be630e611f984454e4f3c489be77
kernel: Hardware name: Acer Aspire AV15-51/Jade_TL, BIOS V1.03 11/08/2021
kernel: RIP: 0010:exc_control_protection+0xc2/0xd0

There’s no way of stopping VirtualBox: I have to kill it brutally. Restarting the computer does not work either. I have to force shutdown.

Is anyone else experiencing this?

These versions do not seem to be in sync:

community/virtualbox 7.0.4-1 (42.3 MiB 180.1 MiB) (Installed)
community/virtualbox-host-modules-arch 7.0.4-7 (255.6 KiB 252.9 KiB) (Installed)
1 Like

I always needed to use the LTS kernel to get them working. Had the exact same symptoms otherwise. I never got to a full root cause as I was just fine being on LTS.

Edit: Just looked closer - use DKMS for the host modules. i.e. install virtualbox-host-dkms 7.0.4-1

Hi, thanks for the reply.

Indeed going LTS worked!

What you suggest, virtualbox-host-dkms is indeed for the LTS kernel. Since I was using the NON LTS one, by following, I installed the corresponding one virtualbox-host-modules-arch.

Good deal. I’m happy to be corrected as I’m not an expert on it but I would always use dkms which will always ensure your modules are synced with the kernel version.

Just to clarify if there is still any confusion: virtualbox-host-dkms is meant for all currently available kernels. But virtualbox-host-modules-arch is meant for linux only.

1 Like

So I could use the former even with “linux” kernel? The wiki says “for any other kernel”, which seems to imply that it cannot be used with “linux”.

Yes, virtualbox-host-dkms will work with any and all kernels, including linux.

virtualbox-host-modules-arch has pre-built modules for the linux kernel, while virtualbox-host-dkms builds the modules for each kernel, including linux.

1 Like

Then I’d say the wiki should be updated :wink:

Using virtualbox-host-dkms instead of virtualbox-host-modules-arch means

  • install kernel headers and dkms (if not already installed)
  • slower installation because of building from source code

I my experience - the best method to avoid issues with VirtualBox VMs over time is

  • install linux-headers for your kernel
  • use virtualbox-host-dkms
  • no extension pack

The time required to rebuild the host modules on kernel change is minimal.


Better stabililty for your virtual machines.

The extension pack is build from AUR and highly sensitive to the vbox version.

Functionality provided is

  • Oracle Cloud Infrastructure integration
  • USB 2.0 and USB 3.0 Host Controller
  • Host Webcam
  • VirtualBox RDP
  • Disk Encryption
  • NVMe

You only need this if you are going to use the functionality provided and it is not required for VirtualBox to function.

Hi folks,
Same problem here: Virtualbox is working when on LTS kernel, but not on the latest (6.1.6 at writing). Can’t start any VM (Linux or Windows).
I have guest-utils and host-dkms installed, so are linux-headers.

Try adding ibt=off to your kernel command line and reboot.

The kernel parameter ibt=off is for Nvidia graphics when used with current 12th gen Intel cpu. Not sure what that’s going to do on virtualbox. :thinking:

Hey, no not just for nvidia graphics. That’s for all the cases where this intel’s flow control enforcement can trigger a kernel trap, anyway

1 Like

Okay then …haven’t run across this. I don’t use vagrant. I just use virtualbox. But not anymore since every other update it’s just a complete failure. I’m using vmware-workstation pro instead for my needs.

Hi, thanks @jake99 for the tip, it worked for me!
And, indeed, I also have a NVIDIA Corporation TU117GLM [T600 Mobile] chip.

1 Like

I have 12th Gen Intel with just integrated graphics, and adding ibt=off did fix this problem for me, so I think you’re right.

Same situation here, 11 Gen Intel with integrated graphic and this solved the problem for me.