Cannot start sddm after removal of nvidia graphics card

Desktop with nvidia GT216. Intel graphics built-in. Using nvidia-340xx-dkms from AUR. Works fine until suspends. Then have all sorts of screen ‘noise’ unless restart desktop (plasma or gnome do the same).

I would like to remove the card and go back to the onboard intel. I have tried removing nvidia-340xx-dkms, xf86-video-intel and xf86-video-vesa are installed.

when I reboot sddm does not start - no login box, just a cursor.

This is the inxi graphics section with the nvidia card in.

Device-1: NVIDIA GT216 [GeForce 315] vendor: PC Partner Limited / Sapphire
driver: nvidia v: 340.108 alternate: nouveau bus ID: 01:00.0
chip ID: 10de:0a22
Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: nvidia
unloaded: modesetting,nouveau,vesa alternate: fbdev,nv display ID: :0
screens: 1
Screen-1: 0 s-res: 1600x900 s-dpi: 92 s-size: 442x251mm (17.4x9.9")
s-diag: 508mm (20")
OpenGL: renderer: GeForce 315/PCIe/SSE2 v: 3.3.0 NVIDIA 340.108
direct render: Yes

inxi with the intel

Device-1: Intel Core Processor Integrated Graphics
vendor: Acer Incorporated ALI driver: i915 v: kernel bus ID: 00:02.0
chip ID: 8086:0042
Display: x11 server: X.Org 1.20.9 compositor: kwin_x11 driver: intel
display ID: :0 screens: 1
Screen-1: 0 s-res: 1600x900 s-dpi: 96 s-size: 423x238mm (16.7x9.4")
s-diag: 485mm (19.1")
OpenGL: renderer: N/A v: N/A direct render: N/A


after the removal of the dkms package you regenerate the image ? (mkinitcpio -P )

for suspense i dont know, mayby also a /etc/default/grub output and /etc/mkinitcpio.conf

make sure to not have any settings for the nvidia driver inside /etc/mkinitcpio.conf and under /etc/x11/xorg.conf.d/
And as @ringo say rebuild kernel images

sudo mkinitcpio -P

Thanks @ringo and @joekamprad
Nothing inside /etc/mkinitcpio.conf for nvidia, nothing in /etc/X11/xorg.conf.d
Rebuilt images. Same result with sddm.
Managed to start with lightdm - but plasmashell crashed. Restarted and then the font rendering was degraded.
Have put the card back in meanwhile (and reinstalled the nvidia drivers) as I need to do some work.
Thanks again - I have set the power settings not to suspend meanwhile!

in the grub you have to see the source of resume= to the correct uuid or part-uuid
and in mkinitcpio look in the hooks for resume …

also sddm has also a bug when drive is near full it give blackscreen.

Hmm… could be that you have to remove settings within plasma for sddm, could be including some monitor settings or such GPU related …
After last update of plasma there are some changes on that possible…
(i do not say that i feel like plasma configs acting a bit like a virus :wink: )


Hi @ringo
Nothing for resume= in either
Drive is not close to being full.
I think when I have some time I will just do a re-install without the nvidia card.

in grub like root= , resume= tells where the swap drive is… there they store ram data intoo it.

if resume not in the mkinitcpio hooks & not resume= in grub it goes to suspended it face some data loss from ram i think (not disk).

sddm does works for most gpu there must be some iissues i cant tell

Hello @ringo
I have no swap drive.
I think maybe I should close this (how do I do that?) as I don’t want to waste any more of anyone’s time. I will continue with the nvidia card in for now without suspend and then reinstall or maybe try a fresh install in another partition later.

not a problem, its no waste of time :slight_smile: as videocard is always your own choice but 340-xx remind its old also the exploration date idk :slight_smile:

As nvidia 340xx driver is no more supported by Nvidia (afaik), it really may be best to reinstall without the nvidia card. Old nvidia drivers will not work with other software, like latest xorg, eventually.