Cannot start EOS at all

I’m writing this from that other OS that shall remain unnamed :wink:
Last night I started a yay, and left the machine to process the 700+ mb of work it needed to do. I came back to find the caps lock light flashing, and the system locked solid.
Rebooting into any of the 6 kernel options (zen, lts, normal, with each of their fallbacks) now fails, as the system does the same thing before reaching X.
I am able to pass the encryption key, get to Grub, and make the choice there to get to the dual-boot other OS on the NVMe shared with EOS.
Laptop: Asus G531gt, Nv1650 optimus.
I ran a memory diagnostic from the other OS, it passes, as does a disk check.

So I am expecting the issue to be one of the NV drivers again, right? And if so then I should be able to get to CLI via instructions here: https://discovery.endeavouros.com/system-rescue/how-to-boot-without-a-graphical-environment/2021/03/

I’ll give that a go; just sharing the journey :slight_smile:


Still fails.
BTW I have 2 disks, one is a encrypted 2Tb ssd holding my /home. It looks like it gets to mount this (which doesn’t happen in other OS) and then dies.
So I will next go to another machine and make a latest EOS USB stick to try live boot access of the journal logs and the /home ssd.

Sorry, It looks like there is a problem with one drive the one with encryption. If you can boot to a prompt or use the USB stick, go to the /etc/fstab and comment out the drive and reboot. Maybe just a bad connection or power cable?

1 Like

So here I am on liveUSB, reporting back on what I have found so far:

  • It appeared that the journals were not helpful, and for some reason didn’t make it to the point of crash.
  • Mounting the /home SSD was perfectly fine. Whew.
  • Chroot into the system then : sudo pacman -Syu
    pacman: error while loading shared libraries: /usr/lib/libnghttp3.so.9: file too short :face_with_peeking_eye:
  • sudo pacman --sysroot /run/media/liveuser/7031a955-3454-4c2e-971e-07902e5be3ad -Sc && sudo pacman --sysroot /run/media/liveuser/7031a955-3454-4c2e-971e-07902e5be3ad -Syu
    gives me the ability to update via pacman, but I am seeing gpg errors all over the show.

So now I’m waiting for a pacman refresh keys to finish…

After yay --root /run/media/liveuser/7031a955-3454-4c2e-971e-07902e5be3ad libnghttp --overwrite=“*”
I was able to do a pacman -Syu within the chroot itself…
Off to try to reboot :slight_smile:


Ugh

So I backed up the necessary folders from the old system, and have installed fresh copy of EOS onto the machine, over the old partition that used to house EOS. I tried firstly installing with Grub, but Calamares bombed out when I chose the partition to replace. Having gone with the (new-to-me) systemd-boot, I am wondering about how to attach the encrypted SSD as /home again, the way I used to have it.
Is there a tutorial on this step anywhere?

there is this topic

1 Like

Thanks. It turns out all I needed to do was add the line to /etc/fstab and reboot:
/dev/mapper/luks-6f37db95-e5a3-4272-8883-2b042e04e398 /home/onyx btrfs defaults 0 2

So for anyone else following this, do a ls -la /dev/mapper/ in order to read what the system has found and mapped for encrypted partitions.

1 Like

Mark your reply as the solution. It’ll be easier to search and will close this thread automatically.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.