Cannot open settings at all - important to find a solution

I have EOS budgie on my double boot laptop installed a couple of days ago.

Settings app just disappeared at a random time when I was trying to view a setting and by that time I cannot find a way to bring it back.

I have killed gnome-control-center but nothing, i really don’t know what’s the problem here. I have restarted the pc and shutdown but nothing fixes the issue.

note: I haven’t installed many apps yet, the only things I’ve done is installing some themes, icons etc. Nothing too much.

I would really appreciate if anyone has any idea about that, need to fix that soon.

If gnome-control-center is the setting app you are referring to, you can try launching it from the terminal and checking to see if any output is displayed in the terminal that would tell you where to look. You can just open a terminal and type gnome-control-center.

Of course, if you installed any software without updating your system, make sure you update as that can break your system on any arch-based distro.

1 Like

I can run only with sudo the gnome-control-center app. It pops for 2 seconds and then it’s gone. In the terminal I get all this:

(gnome-control-center:4794): cc-wwan-panel-WARNING **: 01:14:18.400: Error connecting to ModemManager: Error calling StartServiceByName for org.freedesktop.ModemManager1: Unit dbus-org.freedesktop.ModemManager1.service not found.

(gnome-control-center:4794): dconf-WARNING **: 01:14:18.405: failed to commit changes to dconf: Error spawning command line “dbus-launch --autolaunch=50e410170a0742d28b6ae255f3c827e6 --binary-syntax --close-stderr”: Child process exited with code 1
Error creating rfkill proxy: (null)
Segmentation fault

Any thoughts?

Seems that the first error was resolved after I run “systemctl start ModemManager.service && systemctl enable ModemManager.service”

But the second error keep things the same, settings still cannot launch

Don’t run it with sudo. That may break stuff. What happens when you run it without sudo

1 Like

I get this:

(gnome-control-center:1900): GLib-GIO-ERROR **: 01:30:03.474: Settings schema ‘org.gnome.shell.app-switcher’ is not installed
Trace/breakpoint trap (core dumped)

Sounds like a partial upgrade.

Run a full pacman -Syu , and then check your version of the gnome-control-center package against that in the Arch repos.

1 Like

Thanks man,

I run “rm .config/dconf/user” and it fixed that, although I had to remake all theme changes but that’s nothing.

I will run a full upgrade to be sure anyways

1 Like

To sum it up the problem is whenever i click the tab “Multitasking” on the settings app… When I do that then it disappears and I have to type “rm .config/dconf/user” to bring it back.

Is there any way that this could be fixed?

Have you updated your system and rebooted yet?

1 Like

Also did you install some random extensions that no longer work?

Did that, same problem. Settings crash when clicking multitasking tab

Other than nemo, tilix and plank (that I have installed way before this thing happened) I only have some themes installed for widgets, icons and cursor.

**and all seem to work fine

To not have to redo all the settings, alternatively you can just reset the gnome-control-center settings in dconf-editor by changing the last-panel key, unfortunately I don’t even suspect what might be causing this problem, the fact is that the last panel will always start and if it is having problems, the settings center will not open.

Try switching to Adwaita.

Ah! maybe solve your problem, by the error message

sudo glib-compile-schemas /usr/share/glib-2.0/schemas/

if you don’t have anything app-switcher related I recommend clearing this key recursively in dconf if you use a separate $HOME directory, this could be a remnant of gnome-tweaks configuration.

Captura de tela de 2021-11-15 21-20-49

1 Like