Cannot mount my ntfs hdd

whenever I try to mount my ntfs hdd I get this error:
Error mounting /dev/sdb1 at run/media/user/disk_name : wrong fs type bad option, bad superblock on /dev/sdb1, missing codepage or helper program or other error.

I have installed ntfs-3g.
I have posted my /etc/sdtab here

You may need to run a chkdsk on that partition from within Windows if installed.

This section in an article from ArchWiki might also give you a hint about this issue, how to diagnose and try solving it:

1 Like

I do not see NTFS entry in your fstab

See mine for comparison:
UUID=D04AC8734AC857BC /mnt/data ntfs3 defaults,noatime,prealloc,uid=1000,gid=1001 0 0

BTW. I use ntfs3, it is better

What kernel are you using?

PS. One time I had to boot into to windows, to clear this error. But I suspect in your case it is different

1 Like

thanks for the help. the cmds in the articles worked


Please mark the post pointing out the solution as such.
You could do this by clicking on ... and checking the solution box.
The thread will then be marked as solved and other users with similar issue could find the solution easier.