Cannot mount an external SSD

Hi everybody,
I have an external (usb) 1 TB SSD that I use for backup.
I tried to connect but i receive an error:
I tried to repair the file system using Gnome disk without success.
Help please!

Error text (just in case the image is not visible): Error mounting /dev/sda1 at /run/media/vik19/30A63F8AA63F4F98: wrong fs type, bad option, bad superblock on /dev/sda1, missing codepage or helper program, or other error (udisk-error-quark, 0)

What filesystem was on the drive?

It is NTFS

Do you have ntfs-3g installed?

From the Arch wiki:

NTFS-3G is an open source implementation of Microsoft NTFS that includes read and write support. NTFS-3G developers use the FUSE file system to facilitate development and to help with portability.

1 Like

I don’t think so… how can I install it? is it in the ARC repository?

In terminal, run yay -S ntfs-3g

1 Like

You are probably better off repairing that on a Windows machine since it is an external drive.

ntfs is a Windows specific format.

1 Like

Had exactly the same problem with a NTFS partiton just now, hooked up the USB drive to my Windows laptop, and let Windows check the drive. After hooking it back up to my Linux PC , everything worked ok again.

Hi everybody,
installed ntfs-3g, didn’t work. Still my pc is not able to mount the disk
Installed disk utility, the filesystem repair utility gave a positive, but again I cannot access to the disk.
I connected the disk to my son’s laptop that uses Windows and it was functioning perfectly.
How can I have it working in EndeavourOS?