Cannot login with lightdm

Copied xinit file to user folder and tried to add startup application. Rebooted and cannot login after lightdm screen.

I’ve removed the added line and the copied xinit file and tried rebooting but cannot progress from login screen. TTY still runs fine

What line in which file?
You haven’t said anything about which desktop/WM session you are trying to log into.

Anyway, it seems you are doing the opposite of what was needed, IIUC (with more info, it would be a better assumption).
When you want to use a DM for login, you don’t need/use .xinitrc, since a DM is using any installed session files.
If you login from TTY, then you need/use .xinitrc.

Post:

ls -an "$HOME" | grep -v "^d" 
grep .  "$HOME/.dmrc"
grep .  "$HOME/.xprofile" 2>/dev/null
ls -l /usr/share/xsessions/
cat   "$HOME/.xsession-errors"

image

cat "$HOME/.xsession-errors" generates a couple more lines. I don’t know how to get output as text

image

I’ve tried logging into xfce and leftwm. 2 sec black screen and land back into login

The line was sth like wait 2 sec and launch program which I added to the copied ‘.xinitrc’ file in home directory

1 Like

You could pipe the output of a command to eos-sendlog which will post it to a pastebin and will give you an URL in the terminal. You could post the URL on the forum.

EX:

cat "$HOME/.xsession-errors" | eos-sendlog
1 Like

I’ve restarted lightdm and X. Also removed the .xinitrc from home to see if it works out but still stuck at login. Kernel is 5.18.8-zen1-1-zen

Thanks. A little late reply bc had to read some nmcli stuffs to get connected. Heres the log - https://clbin.com/yOhbV

1 Like

It would be better to boot on the live ISO and provide the hardware info first.

inxi -Faz

Sure. https://clbin.com/SH3fH

Device-1: NVIDIA GA104 [GeForce RTX 3060 Ti] vendor: eVga.com.
    driver: nvidia v: 510.60.02 alternate: nouveau,nvidia_drm pcie: gen: 1
    speed: 2.5 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s ports:
    active: none off: DP-3 empty: DP-1,DP-2,HDMI-A-1 bus-ID: 01:00.0
    chip-ID: 10de:2486 class-ID: 0300

I have no idea what you have been messing with but hopefully you can straighten that out and then add the following kernel parameter at boot to test. If it works then you could add it to the default grub command line permanently and also update grub after.

ibt=off

Edit: You also need the latest Nvidia drivers.

thanks for suggestion.

Didnt know my nvidia drivers are way old. Last time I checked ‘nvidia-dkms, nvidia-utils, nvidia-settings’ were all up to date. Do I need to one of ‘nvidia’ or ‘nvidia-open’ packages

Did you install with the offline version?

Edit: Should be able to just run an update.

sudo pacman -Syu

Yes the install was offline. I have dkms version at 515.57-1

But you have 510.xx drivers. So what I’m saying is try the ibt=off parameter and update to the latest drivers.

1 Like

I assume that was with the liveuser ISO…

Is that what is on the live ISO? OP said they used the offline install?

archisolabel=EOS_202204

Looks like it is the older ISO…

@mushrooms
It is recommended to download the latest EndeavourOS ISO:
https://endeavouros.com/latest-release/

EDIT: the ISO wasn’t your original problem… just re-read the initial post.

1 Like

ok uh I installed nvidia package and wrote ibt=offin grub permanently.

Gave up and restored timeshift snapshot. System was up running before I messed up with the copied .xinitrc file in home folder and pacman update. Nope. Idk why it still persist after timeshift restore so I’m gonna get it a clean reinstall.

Thanks I will.

You have marked it as solved after a package update. Was this by mistake, or just trolling :smile: ?
There is much info you haven’t shared about your system, so everyone makes different assumptions.
For example:

  • Was this system ever working?
  • Was this user account/session ever working?
  • Did you implement a user/local nvidia setting?
  • Have you modified your user group, or anything on your user account?

It seems the group ID is not same with user ID.
There is a nvidia-settings-rc file in your $HOME.
The error messages suggest there might be a permissions problem, but not sure.
Restoring a snapshot does not (normally) restore user folders contents.

I can’t stop myself from posting some Off Topic remarks… :rofl:

  • Even if you made a mistake in one command, it gave correct results

$Home/.dmrc ==> $Home=null, so .dmrc was read succesfully, being in PWD=$HOME

  • Username=user and Hostname=computer look funny, but is still less funny than Username=error and Hostname=failed :smile: (a real case I faced some years ago…)
1 Like

I agree with all that you are saying. I am not an expert and it makes things difficult when users don’t share all the information and also the information that is necessary to make some kind of determination. It is only solved based on my assumptions because I’m guessing at a lot of things based on reading through the lines. I’ll be the first to admit there is a lot i don’t know but i try to use what i do know to help. That is difficult when having to guess at what’s really happened to cause the problem. :man_shrugging: I’m glad that the user has got it working again. If it was restored and still didn’t work then most likely it was more of a problem.

1 Like