Cannot Install Ubuntu Based Distros to SSD (Only Endeavour Installer Works)

Edit: I have edited the title, I don’t believe this has anything to do with EndeavourOS or Arch now, but rather an issue on the Ubuntu installers that is not shared with Endeavour.

My progression on this desktop was Mint → Manjaro → EndeavourOS. After a lot of time spent, I’ve come to the conclusion that Arch based distros don’t fit my use case very well.

Having a VERY frustrating (and concerning) issue right now trying to format my desktop to a Ubuntu based distro. Even using the “guided install - entire desk” option on multiple distributions (Mint, Kubuntu) results in a non-bootable drive after installation. I do not receive any error during installation, just a non-bootable system afterwards.

After multiple install failures I decided to attempt installing EndeavourOS again - it boots right up after the installer completes off the USB drive.

I’ve checked the USB drive for bad blocks. I’ve confirmed the SHA256 sums of the OS’s I’m attempting to install. When on Kubuntu live, I even attempted completely rewriting the partitioning table on the SSD (GPT) to make sure it was 100% empty for the Kubuntu install. It still wouldn’t boot.

Only EndeavourOS can install and boot successfully now. Any help would be greatly appreciated, when I was first attempting to change the distro on this PC I had an important 10TB drive plugged in, and I saw something during this weird process on that drive that is somewhat concerning. I don’t think at this point I have data loss, I’ve unplugged all drives other than the SSD at this point as well, but I really want to get this system booted back up ASAP so I can check.

EndeavourOS doesn’t do anything special to your drive. If you pick the entire disk method, it writes a new partition table and then creates the partitions.

There should be no barrier to installing another OS. If you are having trouble installing an OS, we would need to understand exactly what you are seeing. My best guess would be it has something to do with the fact that you are trying to install to a USB device.

That being said, it would probably make sense for the distro which you are trying to install to provide support for your install in this scenario.

Are you able to give some hardware info? Boot on it if installed and working or use the live usb with internet.

inxi -Faz --no-host | eos-sendlog

I’m considering that as well - that the issue could be with the installer from Mint/Kubuntu and nothing to do with Endeavour. Honestly if I’m completely wiping the drive, like you said I think that must be the case (issue with Ubuntu installer).

I’m not installing the OS to a USB, it’s going onto an internal SSD - I’m just using a live USB for the installer.

I’m not seeing any error messages, at all, which is making this hard to identify as well. Installer closes out, asks to reboot, no error. On restart I just never hit GRUB, it just sits at the UEFI splash screen. You’re right, this may be a question more for Mint/Ubuntu.

Rick, I will boot again and run that for results.

I would be curious if KDE Neon(which is Ubuntu-based) works. It uses the same installer as EndeavourOS.

For me it sounds like a UEFI/CSM problem.

It could be, that EndeavourOS detects correctly that it runs under UEFI. And thats why its bootin.

You could check your UEFI Settings for CSM. If enabled, disable it. And check the Bootentrys wich are available.

1 Like

I agree it could be related but hard to tell at this stage. I would also have CSM disabled, Secure boot disabled obviously and set it to UEFI mode only.

Edit: Obviously if it was already installed with EOS secure boot would be off.

Here is the output from inxi, I ran this off of a Kubuntu live so I was unable to pipe it to eos-sendlog (let me know if you want and I can go into an Endeavour desktop and run it again). Thank you Luna and Rick for the input, I will check CSM settings, i think it should be disabled. I will also attempt booting to Neon and see if I’m able to get that installed correctly.

Thank you everyone for the help. This is not what I planned on doing today, lol.

Where’s the log?


kubuntu@kubuntu:~$ sudo inxi -Faz --no-host
  Kernel: 5.13.0-19-generic x86_64 bits: 64 compiler: gcc v: 11.2.0 
  parameters: BOOT_IMAGE=/casper/vmlinuz 
  file=/cdrom/preseed/kubuntu.seed maybe-ubiquity quiet splash --- 
  Console: tty pts/1 wm: kwin_x11 DM: SDDM 
  Distro: Ubuntu 21.10 (Impish Indri) 
  Type: Desktop System: ASUS product: N/A v: N/A serial: N/A 
  Mobo: ASUSTeK model: PRIME B550M-A (WI-FI) v: Rev X.0x 
  serial: <filter> UEFI: American Megatrends v: 2423 date: 08/09/2021 
  Info: 8-Core model: AMD Ryzen 7 5800X socket: AM4 bits: 64 
  type: MT MCP arch: Zen 3 family: 19 (25) model-id: 21 (33) stepping: 0 
  microcode: A201016 cache: L1: 512 KiB L2: 4 MiB L3: 32 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 121375 
  Speed: 2959 MHz min/max: 2200/3800 MHz base/boost: 3800/4850 
  boost: enabled volts: 1.1 V ext-clock: 100 MHz Core speeds (MHz): 
  1: 2959 2: 2869 3: 2856 4: 2865 5: 2874 6: 2869 7: 2865 8: 3590 
  9: 2872 10: 2870 11: 2408 12: 2196 13: 2192 14: 2190 15: 2194 16: 2194 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: always-on, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA TU116 [GeForce GTX 1660 SUPER] vendor: Gigabyte 
  driver: nouveau v: kernel alternate: nvidiafb bus-ID: 0a:00.0 
  chip-ID: 10de:21c4 class-ID: 0300 
  Display: server: X.Org 1.20.13 compositor: kwin_x11 driver: 
  loaded: modesetting unloaded: fbdev,vesa display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 3840x2160 s-dpi: 96 s-size: 1016x571mm (40.0x22.5") 
  s-diag: 1165mm (45.9") 
  Monitor-1: HDMI-1 res: 3840x2160 hz: 60 dpi: 122 
  size: 800x450mm (31.5x17.7") diag: 918mm (36.1") 
  OpenGL: renderer: NV168 v: 4.3 Mesa 21.2.2 direct render: Yes 
  Device-1: NVIDIA TU116 High Definition Audio vendor: Gigabyte 
  driver: snd_hda_intel v: kernel bus-ID: 0a:00.1 chip-ID: 10de:1aeb 
  class-ID: 0403 
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus-ID: 0c:00.4 chip-ID: 1022:1487 
  class-ID: 0403 
  Sound Server-1: ALSA v: k5.13.0-19-generic running: yes 
  Sound Server-2: PulseAudio v: 15.0 running: yes 
  Sound Server-3: PipeWire v: 0.3.32 running: yes 
  Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel 
  bus-ID: 08:00.0 chip-ID: 8086:2723 class-ID: 0280 
  IF: wlp8s0 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel port: f000 
  bus-ID: 09:00.0 chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp9s0 state: down mac: <filter> 
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 
  bus-ID: 1-5:2 chip-ID: 8087:0029 class-ID: e001 
  Report: hciconfig ID: hci0 rfk-id: 0 state: up address: <filter> 
  bt-v: 3.0 lmp-v: 5.2 sub-v: 27a4 hci-v: 5.2 rev: 27a4 
  Info: acl-mtu: 1021:4 sco-mtu: 96:6 link-policy: rswitch sniff 
  link-mode: slave accept service-classes: rendering, capturing, object 
  transfer, audio, telephony 
  Local Storage: total: 171.42 GiB used: 2.4 MiB (0.0%) 
  ID-1: /dev/sda maj-min: 8:0 vendor: PNY 
  model: SSD2SC120G1SA754D117-820 size: 111.79 GiB block-size: 
  physical: 512 B logical: 512 B sata: 3.1 speed: 6.0 Gb/s type: SSD 
  serial: <filter> rev: 0A temp: 26 C scheme: GPT 
  SMART: yes state: enabled health: PASSED on: 58d 10h cycles: 2499 
  read: 5.6 MiB written: 5.4 MiB 
  ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Lexar model: JumpDrive 
  size: 59.62 GiB block-size: physical: 512 B logical: 512 B type: N/A 
  serial: <filter> rev: 1.00 scheme: GPT 
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
  ID-1: / raw-size: N/A size: 15.63 GiB used: 210.2 MiB (1.3%) 
  fs: overlay source: ERR-102 
  ID-2: /var/log raw-size: 56.48 GiB size: 55.29 GiB (97.90%) 
  used: 2.4 MiB (0.0%) fs: ext4 block-size: 4096 B dev: /dev/sdb4 
  maj-min: 8:20 
  Alert: No swap data was found. 
  System Temperatures: cpu: 37.1 C mobo: N/A gpu: nouveau temp: 25.0 C 
  Fan Speeds (RPM): N/A gpu: nouveau fan: 877 
  Processes: 339 Uptime: 3m wakeups: 0 Memory: 31.26 GiB 
  used: 1.72 GiB (5.5%) Init: systemd v: 248 runlevel: 5 tool: systemctl 
  Compilers: gcc: N/A Packages: apt: 1973 lib: 1046 Shell: Bash (sudo) 
  v: 5.1.8 running-in: konsole inxi: 3.3.06 

fs: overlay source: ERR-102 

This is mentioned in another post on Mint. I’m trying to figure out what the issue is on it. If it were me i would boot on the live ISO for EndeavourOS and launch gparted and create a new GPT partition. Then shutdown and reboot with the distro you want to install and try again.

Edit: Looks like it might be installed in legacy mode and your system is UEFI. This can happen with CSM on sometimes as the installer gets fooled.

Edit: Make sure CSM is disabled and you have UEFI mode only.

I checked my BIOS settings, CSM was already disabled. I did see one option under “Trusted Computing” that had “Security Device Support: Enabled”. I disabled that, however there hasn’t been any change (attempted reinstalling Kubuntu).

I’ll attempt running Gparted off an Endeavour stick, although I don’t know if that will have different results than when I ran Gparted during the Kubuntu live. I also have yet to attempt installing Neon.

Check and make sure it’s installing in UEFI mode and not MBR (Bios)

Do you know where I can check that? This is definitely more a question for Ubuntu/Mint now, I may make a topic over there depending on what I end up landing on today.

I do know that these distros are complaining if I try to manually partition the drives using their installer. I make one 300MB Fat32 partition and mount it to /boot/EFI, and then allocate the rest of the drive to btrfs and mount it to / - The installer however will complain and say there is no partition for EFI, despite there being one. I ignored this error when installing on my laptop, and the system still booted appropriately.

That’s why I bailed on that and just went with “guided - full disk” to remove that variable. The only reason I bring it up now, is I don’t know if the installer would be asking for the EFI partition were it not installing in UEFI mode.

Edit: Still no change after using Gparted under Endeavour live. Created an empty GPT table, rebooted, Kubuntu install still completes without error but is unbootable. Trying Neon now.

Edit2: The issue is definitely the installer used by Mint and Kubuntu. EndeavourOS installs and boots without any issue, and so does Neon as suggested by Dalto.

I’m going to try setting myself up on Neon for now and see if it works OK for my goals. If I need further help beyond this, I’ll ask on a Ubuntu based forum since this seems to be an issue on their side.

Thank you all very much for your ideas and help, especially since this ended up having nothing to do with Endeavour.

You must use an msdos table, imho. Choose in gparted-menu Device/Create partition table and make it msdos.

Not for UEFI you don’t!

That’s the way I erased my disk. Then I let the installer do all the partitioning on autopilot. Just to create a clean disk.

Edit: I boot UEFI of course

1 Like

This is definitely not the case. I install many linux distros on a regular basis and they all have GPT partition tables on them.

My fault.
I believe you, I just always swept my disks clean with msdos-table before reinstalling. All the UEFI stuff I let the installer do.


I could see doing that. :+1: