Cannot install in UEFI mode: Buffer Too Small

Hi all,

I’m unable to boot an endeavouros-2020.07.15-x86_64 live USB to my desktop. I’m getting a Buffer Too Small error.

I tried two different USBs an EMTEC USB 2.0 and a SanDisk Ultra Flair USB 3.0. I used dd to create the USB.

The USB I think is fine since I was able to install endeavouros in UEFI mode to my laptop but my desktop refuses to boot the USB in UEFI mode. I was able to boot it in legacy mode but I don’t want to install the OS in legacy mode.

My motherboard is a Z97-G55 SLI and I am currently dual booting Manjaro and Windows 10. I want to wipe the manjaro drive with EndeavourOS. I even tried resetting the BIOS to default settings and it still gives the same error.

can you provide

inxi -Fxxxza 

latest version Bios is 1.A ( 1.10) 2016/03/04
https://fr.msi.com/Motherboard/support/Z97-G55-SLI

Ran this on my Manjaro OS on my desktop.

inxi -Fxxxza gives:

System:    Host: dwarfo-manjaro-dt Kernel: 5.4.52-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 root=UUID=6b3d4ad4-67a2-4322-bf09-710bf7dea721 rw quiet 
           cryptdevice=UUID=efeb1053-a6d3-4caa-8e72-21b8c490a4e8:luks-efeb1053-a6d3-4caa-8e72-21b8c490a4e8 
           root=/dev/mapper/luks-efeb1053-a6d3-4caa-8e72-21b8c490a4e8 
           resume=/dev/mapper/luks-efeb1053-a6d3-4caa-8e72-21b8c490a4e8 apparmor=1 security=apparmor udev.log_priority=3 
           Desktop: Xfce 4.14.2 tk: Gtk 3.24.20 info: xfce4-panel wm: xfwm4 dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: MSI model: Z97-G55 SLI (MS-7921) v: 1.0 serial: <filter> UEFI: American Megatrends v: 1.10 
           date: 02/19/2016 
CPU:       Topology: Quad Core model: Intel Core i5-4690 bits: 64 type: MCP arch: Haswell family: 6 model-id: 3C (60) 
           stepping: 3 microcode: 28 L2 cache: 6144 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28010 
           Speed: 2578 MHz min/max: 800/3900 MHz Core speeds (MHz): 1: 3678 2: 3605 3: 3634 4: 3602 
           Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled 
           Type: mds mitigation: Clear CPU buffers; SMT disabled 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: disabled, RSB filling 
           Type: srbds mitigation: Microcode 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA GP107 [GeForce GTX 1050 Ti] vendor: eVga.com. driver: nvidia v: 418.113 bus ID: 01:00.0 
           chip ID: 10de:1c82 
           Display: x11 server: X.Org 1.20.8 driver: nvidia resolution: 1920x1080~60Hz, 1920x1080~144Hz 
           OpenGL: renderer: GeForce GTX 1050 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 418.113 direct render: Yes 
Audio:     Device-1: Intel 9 Series Family HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           chip ID: 8086:8ca0 
           Device-2: NVIDIA GP107GL High Definition Audio vendor: eVga.com. driver: snd_hda_intel v: kernel bus ID: 01:00.1 
           chip ID: 10de:0fb9 
           Device-3: Logitech OrbiCam type: USB driver: snd-usb-audio,uvcvideo bus ID: 1-2.4:5 chip ID: 046d:0892 
           serial: <filter> 
           Device-4: JMTek LLC. ASM107x type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-2.2:3 chip ID: 0c76:161e 
           Sound Server: ALSA v: k5.4.52-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Micro-Star MSI driver: r8169 v: kernel 
           port: d000 bus ID: 05:00.0 chip ID: 10ec:8168 
           IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 1.82 TiB used: 61.73 GiB (3.3%) 
           ID-1: /dev/nvme0n1 vendor: Crucial model: CT500P1SSD8 size: 465.76 GiB block size: physical: 512 B logical: 512 B 
           speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: P3CR010 scheme: GPT 
           ID-2: /dev/sda vendor: Patriot model: Ignite size: 223.57 GiB block size: physical: 512 B logical: 512 B 
           speed: 6.0 Gb/s serial: <filter> rev: 01.5 scheme: GPT 
           ID-3: /dev/sdb vendor: Samsung model: SSD 850 PRO 256GB size: 238.47 GiB block size: physical: 512 B logical: 512 B 
           speed: 6.0 Gb/s serial: <filter> rev: 4B6Q scheme: GPT 
           ID-4: /dev/sdc vendor: Western Digital model: WD1003FZEX-00K3CA0 size: 931.51 GiB block size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s rotation: 7200 rpm serial: <filter> rev: 1A01 scheme: MBR 
Partition: ID-1: / raw size: 456.66 GiB size: 448.50 GiB (98.21%) used: 61.70 GiB (13.8%) fs: ext4 dev: /dev/dm-0 
           ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap swappiness: 60 (default) cache pressure: 100 (default) 
           dev: /dev/dm-1 
Sensors:   System Temperatures: cpu: 41.0 C mobo: N/A gpu: nvidia temp: 40 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 30% 
Info:      Processes: 190 Uptime: 42m Memory: 7.72 GiB used: 2.08 GiB (26.9%) Init: systemd v: 245 Compilers: gcc: 10.1.0 
           Shell: bash v: 5.0.18 running in: xfce4-terminal inxi: 3.0.37 
df -h

Returns?

[dwarfo@dwarfo-manjaro-dt ~]$ df -h
Filesystem      Size  Used Avail Use% Mounted on
dev             3.9G     0  3.9G   0% /dev
run             3.9G  1.7M  3.9G   1% /run
/dev/dm-0       449G   62G  364G  15% /
tmpfs           3.9G     0  3.9G   0% /dev/shm
tmpfs           3.9G     0  3.9G   0% /sys/fs/cgroup
tmpfs           3.9G   24K  3.9G   1% /tmp
/dev/nvme0n1p1  300M   26M  274M   9% /boot/efi
tmpfs           791M   12K  791M   1% /run/user/1000

Here’s a bit more information,

When I boot the USB in UEFI mode it takes me to this boot menu. From there I choose “EndeavourOS UEFI USB”.

After that, this screen shows up for two seconds.

Finally it goes to that blue window screen about “Buffer Too Small” that I mentioned in my first post.
It also freezes at that point, pressing “enter” on the keyboard doesn’t do anything.

Also I tried using Rufus USB creator on Windows 10, it didn’t help either.

Check you bios settings and make sure it’s set to Uefi boot and not legacy or both.
Also since you did you reset it make sure secure boot is off.

And secure boot turned off.

1 Like

Also there should be two boot options in bios for the usb stick choose the one that says partition 2

Ok, so I already had secure boot turned off since I had “Windows 8/8.1/10 Feature” disabled. But I went and enabled that and doubled checked secure boot is disabled.

I made it UEFI only – seems to be the only option since I just enabled the Windows 8/8.1/10 Feature

Now I seem to get this, it doesn’t even take me to the boot menu of the USB installer anymore.

Also there doesn’t seem to be a partition 2 of the usb stick. Only UEFI: (FAT) SanDisk

how did you “burn” the ISO to the usb stick?

sudo dd if=endeavouros-2020.07.15-x86_64.iso of=/dev/sdd bs=4M oflag=sync status=progress

Also I tried using Rufus using mbr and gpt settings.

Never mind.

[dwarfo@dwarfo-manjaro-dt Downloads]$ md5sum -c endeavouros-2020.07.15-x86_64.iso.md5sum
endeavouros-2020.07.15-x86_64.iso: OK

Also the iso image I downloaded seems to match the md5sum.

Try another USB port, a USB 3 one preferably.

3 Likes

Could you redo your usb key with this…don’t forget to replace the path and your X drive :

sudo dd bs=4M if=/path/to/endeavouros-2020.07.15-x86_64.iso of=/dev/sdX status=progress && sync

2 Likes

Nice! That works! I plugged the EndeavourOS USB into a USB 3.0 slot in the back of my PC.
Maybe there’s an issue with my front 3.0 ports? But it works now, I’ll try to avoid using the front usb ports for all future installs :slightly_smiling_face:

5 Likes

You could put @nate as solution… :rocket:

About your front port, they are maybe not well connected on your motherboard !

2 Likes

Yeah, I’ll have to refit my front USB 3.0 connector. :slightly_smiling_face:
Thanks all.

1 Like

then let your endeavour start :slight_smile:

5 Likes