Cannot install gcc8 on recent EndeavourOS


I tried to install gcc8 on fresh install of newest EndeavourOS for the project that require this specific gcc version.
I tried to install it though yay and then by:

but it always ends up with GLIBCXX_3.4.30 problem (part of log below)

libtool: link: ranlib .libs/libstdc++convenience.a
libtool: link: rm -fr .libs/libstdc++convenience.lax .libs/libstdc++convenience.lax
libtool: link: ( cd “.libs” && rm -f “” && ln -s “…/” “” )
make[6]: Leaving directory ‘/home/michaels/.cache/yay/gcc8/src/gcc-build/x86_64-pc-linux-gnu/libstdc+±v3/src’
make[5]: Leaving directory ‘/home/michaels/.cache/yay/gcc8/src/gcc-build/x86_64-pc-linux-gnu/libstdc+±v3/src’
Making all in doc
make[5]: Entering directory ‘/home/michaels/.cache/yay/gcc8/src/gcc-build/x86_64-pc-linux-gnu/libstdc+±v3/doc’
make[5]: Nothing to be done for ‘all’.
make[5]: Leaving directory ‘/home/michaels/.cache/yay/gcc8/src/gcc-build/x86_64-pc-linux-gnu/libstdc+±v3/doc’
Making all in po
make[5]: Entering directory ‘/home/michaels/.cache/yay/gcc8/src/gcc-build/x86_64-pc-linux-gnu/libstdc+±v3/po’
msgfmt -o /home/michaels/.cache/yay/gcc8/src/gcc/libstdc+±v3/po/de.po
msgfmt: /home/michaels/.cache/yay/gcc8/src/gcc-build/x86_64-pc-linux-gnu/libstdc+±v3/src/.libs/ version `GLIBCXX_3.4.30’ not found (required by /usr/lib/
make[5]: *** [Makefile:499:] Error 1
make[5]: Leaving directory ‘/home/michaels/.cache/yay/gcc8/src/gcc-build/x86_64-pc-linux-gnu/libstdc+±v3/po’
make[4]: *** [Makefile:512: all-recursive] Error 1
make[4]: Leaving directory ‘/home/michaels/.cache/yay/gcc8/src/gcc-build/x86_64-pc-linux-gnu/libstdc+±v3’
make[3]: *** [Makefile:419: all] Error 2
make[3]: Leaving directory ‘/home/michaels/.cache/yay/gcc8/src/gcc-build/x86_64-pc-linux-gnu/libstdc+±v3’
make[2]: *** [Makefile:15903: all-stage1-target-libstdc+±v3] Error 2
make[2]: Leaving directory ‘/home/michaels/.cache/yay/gcc8/src/gcc-build’
make[1]: *** [Makefile:23663: stage1-bubble] Error 2
make[1]: Leaving directory ‘/home/michaels/.cache/yay/gcc8/src/gcc-build’
make: *** [Makefile:946: all] Error 2
==> ERROR: A failure occurred in build().
→ error making: gcc8-exit status 4
→ Failed to install the following packages. Manual intervention is required:
gcc8-libs - exit status 4
gcc8 - exit status 4

I tried to downgrade icu but to no avail as it breaks dependency ‘’ required by gspell, harfbuzz-icu and raptor.
I also tried other solutions but none worked.

According the AUR page it is an issue with the package.

Did you try the workaround suggested there?

Edit PKGBUILD and add --disable-nls when the configure script is called.